0 Replies Latest reply on Nov 1, 2012 9:48 AM by DuckSportsFan

    FMS 11 Crash on Demand - ODBC Related

    DuckSportsFan

      I stumbled upon an event that causes FMS 11 to crash, involving an ODBC MySQL setting.

       

      I have a hosted SQL database that I access via ODBC. Everything was fine until I changed the structure of a SQL table field to be encoded as US ASCII (ascii). Not knowing that that was the cause initially, I re-opened the FMS database file. It ran for about 10 minutes and crashed again. I then decided that perhaps my changing the SQL table field to US ASCII has something to do with this crashing, as I've never experienced crashing of my FMS file before. So I changed the SQL table's field back to "blank" encoding, and the FMS file has not crashed since.

       

      Also, there's a bug, or consistent error dialog that will popup when making a SQL field a checkbox on the FMP layout, and the SQL field has any value in it other than "null", initially. When I try to click the checkbox, to put an "X" in it, the dialog will warn the field cannot be more characters than it was set for, and I have to choose "revert" to be able to continue anything else. The "value list" I'm using is only a "1" (one), so the SQL field can only be null, or 1. I tried using a value list of 1 and 0, or starting the SQL field with a value of blank or 0 or even a 1, without success. Only an initial value of null will work.

       

      I'm running FMS 11.0.4.404 on a Mac, and FMA 11.0v4 on a Mac.

       

      One other related item... I run a FMS Schedule "external script" to compress my database backup and copy it to an external network drive. Once the FMS crashed, that script file would not work (error -1 [unknown error]). So I restarted the computer, and the schedule external script file ran like normal. So, if a FMS file crashes, you must restart the computer if you are running a scheduled script file.