AnsweredAssumed Answered

Why is FM server 12 missing files in external container?

Question asked by ericruff on Nov 11, 2012
Latest reply on Nov 12, 2012 by thomas_staehli

FM server 12 can't seem to find my data files in an externally stored container field. I have tried for hours over a period of 2 days to get it to work.

 

The purpose of this database "Client Archives.fmp12" is for storing and viewing documents (mostly .pdfs) of my past clients. Client Archives.fmp12 has a container field "DocumentsContainer" and this is set for external storage in a folder "Archive documents."

 

I have a new mac mini on which is installed both FM server 12 and a copy of FIlemaker Pro 12 which I can use for testing. I also have a mac pro on the same network running FM Pro 12 Advanced.

 

Before I got FM server, I had deployed all this on an iMac at the office where the database was on the iMac and the external container data was on a connected external hard disk. Ran like a charm. Then I thougt it would be great if everyone in our office couldf access these files so I decided to get FM server, thus the mac mini. I brought the mac mini home for testing before I return triumpantly to the office and deploy it there fore everyone. At home I also have my mac pro, so I can do network testing on my project.

 

The first thing was to upload the database to Server. When I tried to use the FM server upload database feature to bring it all into FM server, it didn't work and I got a communication error. I figured the problem was maybe the external hard disk location. Or maybe the fact that my database uses a plug-in (Troi Autmatisering File Plug-in) for which I have a single client copy but not the server version yet. Maybe Server reads every line of script before it will upload a database and was upset by this. I don't see it as a problem because I only use this plug-in for adding new documents to the database, and at this point I just want to see if remote FM clients can view the documents and this does not involve the plug-in. I am treating the documents as a closed set at this point.

 

Amyway, since FM server wouldn't let me upload the databse automatically, I manually uploaded the data base and the the container data to FM server. I believe I got everything located where is it supposed to go on the mac mini where FM Server is installed:

 

for the database: /Library/Filemaker Server/Data/Databases/Client Archives.fmp12

for the external container: /Library/Filemaker Server/Data/Databases/Files/ArchiveClientList/Archive documents/

 

I think I have the ownership and privileges set correctly. I used BatChmod to set Client Archives.fmp12 and all the folders (

Files/ArchiveClientList/Archive documents) as follows:

 

Owner: fmserver and Group: fmsadmin and I checked everything "on" for everyone - maybe overkill.

 

Within the FM Server itself, things look OK. The database Client Archives.fmp12 shows up properly on the databse list. I can Open the file and it shows Status Normal. I can serve it up and access that database remotely from my mac pro on the same network, so the database itself seems to be OK. But when I try to view a .pdf for a particular client in the container field (go to related record), I get a "<Missing: (filename.pdf)>" error.

 

So here is the first odd thing. I can get it to work fine locally on the mac mini using a copy of FIlemaker Pro 12 also installed there instead of server. That is, if I

1) close the file Client Archives.fmp12 on FM server and then

2) stop the server, and then

3) I run FIlemaker 12 Pro on the SAME mac mini where FM server is located,

4) I can open up the the same databse, still located at /Library/Filemaker Server/Data/Databases/Client Archives.fmp12 and with the container documents still located at /Library/Filemaker Server/Data/Databases/Files/ArchiveClientList/Archive documents

 

5) everything runs perfectly! I don't get any missing filename errors, and the .pdf documents display just fine.

 

That tells me that all the paths are correct, for example the setting for

Manage/Database/ for the field DocumentsContainer>Options>Storage> is set to: (checked) Store container data externally relative to: [hosted location]/Files/ArchiveClientList/ and (selected) Open Storage "Archive documents/"

 

I obseve something odd here. The two choices I was offered at this point for "relative to:" were (1) [hosted location]/Files/ArchiveClientList/ and the other (2) [hosted location]/Volumes/Archives External HD/ . The second of these was the old original external hard disk location before I ever got FM Server 12, and I don't know why FM still remembers this. But that's not the odd thing. The odd thing is the reference in choice #1 which was to the location "[hosted location]/Files/ArchiveClientList/ " I understood the reference to [hosted location]/Files/, but certainly not the reference to "ArchiveClientList/" I don't know where this language came from. On the other hand, FM was only giving me 2 choices and I sure didn't want to select the old external hard disk, so I picked choice #1. However I could see that FM was now adamant that within the FIles folder there ought to be another folder called "ArchiveClientList" so I made one up, stuck it inside

 

/Library/Filemaker Server/Data/Databases//Files/

 

and put my "Archive documents" folder inside the new AchiveClientList folder, so the complete path for the externally stored .pdf documents is:

 

/Library/Filemaker Server/Data/Databases//Files/ArchiveClientList/Archive documents/

 

So, why all this works fine with FIlemaker Pro 12 but not with FM Server 12 is the mystery to me. Anyone?

 

Thanks,

 

Eric

Outcomes