AnsweredAssumed Answered


Question asked by dloughlin on Nov 16, 2012

I am having problems with fastcgi timeouts. It's on a windows server 2008 IIS6, using Filemaker Server Advanced 12. PHP initiated filemaker scripts that take longer that 30+ seconds to run get the fastcgi timeout error. If I look at the fcgiext config file that is in the Program FilesFileMakerFileMaker ServerWeb Publishingpublishing-enginephp folder, the ActivityTimeout and RequestTimeout are both set at 600 (apparently by the FileMaker Server Installer). It appears to be ignored. One interesting thing I did find, is that when I go into the IIS Manager, and I look at the FastCgiModule registration, it contains "%windir%System32inetsrviisfcgi.dll". I'm wondering if it should be pointing to a dll in the Filemaker folder. Before I start changing any of these settings, I'm wondering if anyone has any experience with these settings and can shed some light for me on why I'm getting the timeouts, or perhaps can point me to some documentation that can.

Thanks in advance for any assistance.

FYI, the same software at a different client location, running with IIS7, does not timeout.