1 Reply Latest reply on Dec 10, 2012 4:06 AM by sicoa

    Delay when trying to load a value list in a portal through IWP

    sicoa

      I have a layout displaying in IWP in which I have a portal that has a field which I populate from a drop down value list.

       

      The value list comes from a field in another table and brings all values of that field. The value list has something like 20 values (which are the names of the users of the system).

       

      When I click in the portal->field it takes IWP something like 15 seconds to return the screen with the drop down list populated so I can select the value I want. The records in the table that is represented by the portal has around 20 records in total of which only one is related and displaying. So there is really no huge amount of data that could be delaying it.

       

      Does anyone have any ideas?

        • 1. Re: Delay when trying to load a value list in a portal through IWP
          sicoa

          Ok so obviously there is an issue when you are bringing a significant amount of data from a related TO into an IWP screen with a portal. What I have ended up doing is setting the whole screen up to use a standard list layout.

           

          However I am having issues with long value lists that are generated by a field. So I am assuming this is also a limitation in IWP.

           

          Now looking to try and fix this again through List layouts.

           

          My issue is that I want to assign a client to a case/project but when I click the drop down list with the client id and full name it takes around 30 seconds to bring back a value list with around 3000 entries (on the client you get this in less than a 2 seconds).

           

          Any suggestions?

          1 of 1 people found this helpful