11 Replies Latest reply on Apr 15, 2013 8:54 AM by SecretWeaponLabs

    FMP 12 with Win 7, 64 bit file not modifiable issue?

    OnlineRiverSoftware

      FMP 12 works fine by itself.

       

      But if we install a runtime (Program.fp7), or a multi-user Program file, in the C drive, program files folder, the Program File (Program.fmp12 for example)...........and try to open the program...

       

      User gets the error "This file is not modifiable"

       

      Apparently the PERMISSIONS is restricting the folder and the application within it.

      If we open the multi-user solution,...we get the same error message as with the runtime.

       

      TO SOLVE this, we have to manually change the Permissions to include WRITE and MODIFY or if we turn off USER ACCOUNT CONTROL and if the user is an Administrator then it works fine too.

       

      ANOTHER SOLUTION is to go to Compatibility Tab in Properties and check "Run in 32 bit mode as XP, etc..." and then it works fine.

       

      If we put the runtime, for example on the desktop or in My Documents folder, it works fine, but we would like to install our program folder in the C Drive and keep all parts of our solution together in one folder - there must be a way to do this automatically so the customer does not have to make changes to their PC?

      It works fine in XP or VISTA or Win 7, 32 bit - just not in Win 7, 64 bit mode

       

      To experience this you need to be working with either a runtime, or a multi-user solution where FMP 12 opens your solution (not just FMP 12 alone).

       

      Doe anyone have some suggestions or insights?

       

       

      Thanks,

        • 1. Re: FMP 12 with Win 7, 64 bit file not modifiable issue?
          Steve Wright

          Since Vista, Microsoft has changed the way the "program files" folder is used, to an extent anyway.

          You should not store any user data files in there period.

           

          Not only will you face privelage issues, but also further problems down the line as the data files will might be read from

          C:\Users\[username]\AppData\Local\VirtualStore\Program Files (x86)\AppName or a location to that effect.

           

          I noticed this when I first tried to update a solution which used the program files path, nothing ever changed, it had me scratching my head a little.  It appeared to update fine, then when I launched it, it was always the previous version still.

           

          Heres a simple test, put a runtime in c:\program files (x86)\AppName\  

          Launch it and  change some data.

          Now delete all the runtime files, i.e all .fp7 .usr or .fmp12 depending how you built the runtime, but leave all executables.

          Launch the solution again  (yes it should work and at first you would think WTF)

          Edit: See note below

           

          This is because it copied the user data files to the virtual store and is now using them from that location.

           

          I dont have the best answer for this problem though... at the time (and still do) I started to install directly to the root C:\AppName

          This has not been a problem for me since vista through to windows 8, but its not the correct way it should be done.

           

          I will be looking into a proper deployement with my next solution, so I will bookmark this myself too in case a better solution arises

          What I do know is that program files should go in "Program Files" and data should go in AppData (as above), I have just not attempted a deployment like this yet.

           

           

          Hope this helps somewhat.

           

          Edit: Just tried this with a copy of a solution we currently distribute and am seeing different results (its based on FM11)

          However I also have an older solution which is based on FM8, this one does exactly what I described above whereas the v11 solution has not created files in the virtual store, it was only a quick test though to confirm what I was saying was somewhat accurate   something may be different which I was unaware of due to not persuing it for some time.

          • 2. Re: FMP 12 with Win 7, 64 bit file not modifiable issue?
            Steve Wright

            On a side note, I use a digitally signed installer built with INNO setup, within INNO you can specify the privelages of individual files so for instance, can set WRITE and MODIFY privelages

             

            However this is not recommended to do within the program files because you are still storing data in a folder not designed for data so to speak.
            I can't seem to find much info on this subject via google, so perhaps most dev's have resorted to installing directly in C: or into the Documents area.

             

             

             

            INNO example setting permissions:

             

            Source: C:\RuntimeBuildFiles\AppName\FileName.ext ; DestDir: {app} ; Permissions: users-modify

             

            ^ This is the reason my solution worked ok when I tried it earlier.  Although with these extra privelages removed I still did not get the virtualstore 'copy' of the files like I do with the FM8 runtime.

             

            Edit:

            See "Data Redirection" here:

            http://technet.microsoft.com/en-gb/magazine/2006.05.firstlook.aspx

            • 3. Re: FMP 12 with Win 7, 64 bit file not modifiable issue?
              OnlineRiverSoftware

              Thank you very much for your answers so far.

               

              Would you or anyone else know the answer to this:

               

              In creating multi-user solutions, and bundling the solution with FMP with FMP 12 Advanced,  we would like to hide the Assisted Install.txt file .........A previous developer was able to hide the file in a .mpkg file on the MAC.

              Does anyone know how to do that?

               

               

              And if so, we would like to do the same on the PC - we have found references to using Orca to create or modify a .msi file.

               

              Any suggestions?  Thank you.

              • 4. Re: FMP 12 with Win 7, 64 bit file not modifiable issue?
                BillMiller

                HI,

                I'm having the same issue of permissions errors when I develop a FM runtime solutions.

                And yes, I've found the same three solutions, all requiring a manual adjustment by the end user:

                1. Login as Admin

                2. Set .exe runtime to 'run as administrator'

                3. Set .exe runtime Properties/Compatability to 'run in xp compatability' mode.

                 

                I've tried 5 different installers and none have provided a solution.

                 

                I like the simple idea you have suggested of installing to 'documents'.

                Thanks,

                bill

                • 5. Re: FMP 12 with Win 7, 64 bit file not modifiable issue?
                  Steve Wright

                  I've tried 5 different installers and none have provided a solution.

                   

                   

                  Inno Setup (as above) allows you to change the permissions during install, but the program folder is not the place for user data, hence the problem in the first place.

                   

                  Have you tried installing to the root of C:?  I have done this since Vista and had zero problems, although you may still have issues in a corporate environment, but none of my users have been an issue to date.

                   

                  Having a hard-coded data source path doesn't help considering that the user-directories are all within a 'user-specific' folder, i.e their username.

                  If FM ever did let us assign data sources another way, such as through a variable, config.ini (and mac equiv) or registry etc, then there would be an easy solution.

                   

                  Inno setup also allows you to make file assocations, so if you where to separate the data files from the executables, you could associate your extensions with the runtime exe, problem is.. the runtime exe doesn't know where to look, but you could probably create a shortcut to the main solution file instead.. Ive not tried this though, just an after thought.  Kind of like opening a word doc directly, rather than opening word itself then the document.

                  • 6. Re: FMP 12 with Win 7, 64 bit file not modifiable issue?
                    Steve Wright

                    We perform a silent install of FileMaker, the install itself is packaged within our installer and extracted to a temporary folder.  Once the install is complete, the temporary contents are removed.  Whilst this does not hide the file during install, its not accessible before or after.  

                    • 7. Re: FMP 12 with Win 7, 64 bit file not modifiable issue?
                      BillMiller

                      Thank you!

                      I'll give that a try.

                      Thanks for your help.

                      • 8. Re: FMP 12 with Win 7, 64 bit file not modifiable issue?
                        OnlineRiverSoftware

                        Steve,

                         

                        We have a client with Windows Server 11 Small Business Edition

                         

                        They can load FMP 11 and open it fine, but they are having no luck connecting from other PC's to it.

                         

                        Any ideas?

                         

                        Thanks

                         

                        Todd

                        • 9. Re: FMP 12 with Win 7, 64 bit file not modifiable issue?
                          Steve Wright

                          Hi Todd,

                           

                          In my experience there can be a number of reasons for this, the most obvious being firewall's.
                          Here is an article on ports which may require opening in the firewall or re-directing via a router (port forwarding)
                          http://sixfriedrice.com/wp/filemaker-firewall/

                           

                          When 11 loads are their any error messages relating to FM not being able to share files?

                           

                          Other things which spring to mind..

                           

                          Can you ping the server from a client?

                           

                          If you go to File > Open Remote and manually enter the location under "Network Path" can you connect this way, if so it may be a problem with Bonjour's install (or lack of).  If I remember correctly, without bonjour the hosted files will not show on client machines.

                           

                          Try adding the host's IP to the favourite hosts (via open remote) I have done this in the past and it resolved a similar issue.

                           

                          In all honesty though, since 11 I have had very few connection related problems.  With 9 I had tonnes relating to the certificate files corrupting themselves (root.pem and server.pem) although this hasn't been an issue for a long time.

                           

                          There may be more, but thats all that I can think of at the moment   hopefully something above will help.

                          • 10. Re: FMP 12 with Win 7, 64 bit file not modifiable issue?
                            BillMiller

                            Hi, I had the same problem with my runtimes.

                             

                            It seems that in Windows 7, they added a requirement to separate the program from the data, and everything contained in the Programs folder, now is defaulted to be non-modifiable program files, while the actual data (which can be modified) is elsewhere.

                             

                            That is why the program works when you do not install it in the Programs folder.

                             

                            So I just install my FM runtimes elsewhere or on the desktop.

                            • 11. Re: FMP 12 with Win 7, 64 bit file not modifiable issue?
                              SecretWeaponLabs

                              Just to answer your question (I just solved this myself), to hide the Assisted Install.txt file:

                              1. drag your installer folder/drive into the Terminal on Mac
                              2. then type the following setfile -a V "Assisted Install.txt"
                              3. then hit Enter
                              4. Assisted Install is hidden, but useable