8 Replies Latest reply on Jan 10, 2013 5:20 AM by Mike_Mitchell

    File size limit on SuperContainer?

    Mike_Mitchell

      Good day. Been using SuperContainer for a while on several solutions, and just ran into something interesting. The customer was trying to upload a largish (~34 MB) PDF to a SuperContainer web viewer, and was unable to do so. The operation returned a "404" error. After some experimenting, I was able to determine that the cutoff appears to be somewhere around 30 MB. Does anyone know if this is normal behavior for SuperContainer, or is there something munged up in my setup?

       

      Thanks!

       

      Mike

        • 1. Re: File size limit on SuperContainer?
          Shauniedarko

          I set up SuperContainer at my last job, and they used it to store CAD files that were pretty big.  I can't be 100%, but I'm pretty sure at least some of them were over 30 MB.  I'm also pretty sure that SC doesn't have a size limitation AFAIK, but you might check out their forums.  They're actually really great at replying with the answer.  I'd love to know if you get a concrete answer to this.

          • 2. Re: File size limit on SuperContainer?
            datastride

            Mike,

             

            We regularly upload files exceeding 150 MB to SuperContainer. The trick is to give the Java code more stack space. But there's a trade-off, as memory you allocate to Java can quickly push up the total memory usage, so best to use a 64-bit OS if you give Java a lot more memory. Other wise your server OS may run out of memory.

             

            I would write to Jesse or the support teamat 360Works, and they can give you the details for changing the amount of memory Java is allowed to use as appropriate for your server OS.

            1 of 1 people found this helpful
            • 3. Re: File size limit on SuperContainer?
              taylorsharpe

              I'm sure Jesse Barnum or one of the other 360 Works guys can help you on SuperContainer.  They have a blog on their 360Works web page and you might want to post this question there. 

               

              FYI, in FM12, I created a Container field and put a 292MB file in it and it worked.  Granted it was slow, but it worked. 

              1 of 1 people found this helpful
              • 4. Re: File size limit on SuperContainer?
                Mike_Mitchell

                Thanks, Morgan. That might be it; we're a bit memory-restricted on this server and it might be timing out. I'll investigate.

                 

                Mike

                • 5. Re: File size limit on SuperContainer?
                  Mike_Mitchell

                  Thanks, Taylor. I have it in the plan to upgrade the solution to v12 so I can use external containers; just haven't gotten there yet.   

                   

                  Mike

                  • 6. Re: File size limit on SuperContainer?
                    Mike_Mitchell

                    Update: I contacted 360Works, and they put me on to the problem. Turns out under IIS7, there's a default 30MB upload limit. The kind gentleman there gave me some code to insert in the web.config file that changed the limit, and now things are working nicely.

                     

                    Thanks for the assist, gentlemen!

                     

                    Mike

                    • 7. Re: File size limit on SuperContainer?
                      LyndsayHowarth

                      out of interest Mike... did he point you to the php.ini? I know this limit is set there.... for PHPP uploads. So... does thee iiS have a separate setting too?

                       

                      Sent from my iPad

                      Lyndsay Howarth

                      11th Hour Group Pty Ltd

                      • 8. Re: File size limit on SuperContainer?
                        Mike_Mitchell

                        No, just web.config. So yes, it appears that IIS operates independently of the PHP engine. And that SuperContainer only cares about the IIS setting.

                         

                        Just for everyone's reference, here's the code:

                         

                        <system.webServer>

                        <security>

                        <requestFiltering>

                        <requestLimits maxAllowedContentLength="2000000000"/>

                        </requestFiltering>

                        </security>

                        </system.webServer>

                         

                        Has to go inside the <configuration> tags, and be properly indented. In my case, there was already an opening and closing <system.webServer> tag, so I just added the other stuff.

                         

                        Mike