11 Replies Latest reply on Mar 19, 2013 8:14 AM by justinc

    Admin Server Console and Java 7

    psuchad

      Here's a warning for those heeding the announcement at the top of the forum to update to Java 7 Update 11. After you install Java 7, you will not be able to recreate your server console link. This is true at least on Windows Server 2008 R2. If by chance you delete your console shortcut, you will need to download Java 6. I think Java 6 Update 16 was the last version that I could get the console shortcut to generate.

       

      Edit: Once the shortcut is created using Java 6, you can uninstall Java 6 and install 7. The shortcut should still work.

        • 1. Re: Admin Server Console and Java 7
          dchabot

          Chad,

           

          I'm running FMS11Adv on Mountain Lion client, and encountered the same problem after updating Java to 7.

          I use the Java link created in the Java app (I created an alias) which opens the Admin console login.

          It seems to be working ok while waiting for a fix.

           

          D.Chabot

          • 2. Re: Admin Server Console and Java 7
            wimdecorte

            While the shortcut is handly, you don't really need it.  Just point your browser to the ip address of the server on port 16000.  You can add a shortcut to that if you don't want to jump through the install/uninstall hoops.

            • 3. Re: Admin Server Console and Java 7
              dburnham

              I am struggling with what I think is the same issue.  Mountain Lion Server running after erasing the hard drive and reinstalling the OS.  Then, FileMaker Server installs, but it can't launch the start page.  The browser times out.

               

              The ports (16000, 160001) are both open, as confirmed by Network Utility.  The Web Server is running, I can see the server's default page from the server itself and from outside the server's local network.

               

              Attempts to start the AdminServer using the Terminal command  fmsadmin start adminserver  results in Error: 10006

               

              I have uninstalled and reinstalled FMS numerous times.  I've tried using Java version 10 and Java version 13, each time following Oracle's instructions to uninstall Java by moving this file to the Trash:  JavaAppletPlugin.plugin

               

              I think I would like to go back to the place where FMS installer puts its own version of Java in place, but I can't seem to get to that and I've like to avoid having to wipe the HD again.

               

              Any ideas will be welcome.

               

              Dennis

              • 4. Re: Admin Server Console and Java 7
                BruceHerbach

                Hi Dennis,

                 

                This is a common problem in part caused by Apple shutting versions of Java down due to security risks.  Take a look at this thread.  https://fmdev.filemaker.com/message/106406#106406

                About half  way down there is an entry by John ( PointinSpace ) that describes how to enable Java 6.  If you have Java 6 installed but deactivated then this might get you going. 

                 

                By the way I had done this back on the first.  Yesterday Apple must have released an update to Xprotect.  I wasn't able to run the console and had to re-apply the fix in John's post.

                 

                I had the same problem a month or so ago when Apple re-installed the OS on my FMS server. When it came back Java wasn't installed at all.  The first time I ran the console,  FMS had the install Java button the Start Admin web page.  This actually installed 6 but the XProtect stuff kept it shut off.  I came accross another setup that put Java back on line.  If this doesn't work,  let me know and I'll see if I can find the instructions for that.  It was a bit more complex.

                 

                HTH

                Bruce

                • 5. Re: Admin Server Console and Java 7
                  dburnham

                  thanks Bruce - I will try the link and report back.

                  • 6. Re: Admin Server Console and Java 7
                    dburnham

                    Here are my results:

                     

                    DID THIS FIRST

                    To re-enable Apple Java 1.6:

                     

                    sudo /usr/libexec/PlistBuddy -c "Delete :JavaWebComponentVersionMinimum"

                    /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta.plist

                     

                    RESULT:

                    Usage: PlistBuddy [-cxh] <file.plist>

                        -c "<command>" execute command, otherwise run in interactive mode

                        -x output will be in the form of an xml plist where appropriate

                        -h print the complete help info, with command guide

                     

                     

                    DID THIS NEXT

                    sudo defaults write

                    /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta.plist

                    JavaWebComponentVersionMinimum \"1.6.0_37-b06-434\"

                     

                     

                    RESULT:

                    fm:~ dburnham$ /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta.plist

                    -bash: /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta.plist: Permission denied

                    fm:~ dburnham$ JavaWebComponentVersionMinimum \"1.6.0_37-b06-434\"

                    -bash: JavaWebComponentVersionMinimum: command not found

                    fm:~ dburnham$


                     

                    THEN I FOLLOWED THIS INSTRUCTION

                    To re-enable Oracle Java 1.7u11 (don't think this is necessary now with

                    the latest Java update released today):

                     

                    edit the

                    "/System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta.plist"

                    using vi in Terminal and change:

                     

                    1.7.11.22

                    to:

                    1.7.11.19

                     

                    I drilled down in the CoreServices and opened CoreTypes.bundle with BBEdit, and edited the XProtect.meta.plist file as shown here, changing 22 to 19

                     

                    I also went into System Preferences to follow this instruction:

                    These changes will only work until Apple updates the XProtect file

                    again.  You can fix this by disabling XProtect updates, though I can't

                    say that's necessarily prudent:

                     

                    Go into system preferences - Security & Privacy

                     

                    Under general tab, click advance button, tick off the automatically

                    update safe download list

                     

                     

                     

                    I still can't get the Admin Console to launch using the Start Page.  When I type localhost:16000 into a browser, it just times out.

                     

                    Hoping to avoid erasing the hard drive again, because it means another trip to the data center, and hours of waiting time for Mountain Lion to re-install.

                    • 7. Re: Admin Server Console and Java 7

                      Hi Dennis,

                       

                      I now believe there's less effort to learn the Terminal Commands and administer the server with certainty, than chase the endless tail of Java installation quirks with all the time wasting entailed.

                       

                      Many folk will choose to disagree with this suggestion but that's their prerogative!

                       

                      John

                      • 8. Re: Admin Server Console and Java 7
                        dburnham

                        Thanks, John, I confess to not having as much experience with Terminal as I should, but I'm trying to become proficient with it.

                         

                        Here's a further report to what I wrote earlier to Bruce:

                         

                        Even though I was unable to get the Admin Console launched on a new installation of FileMaker Server v.12.0.2.232, I went ahead and ran the updater to bring myself forward to FMS v.12.0.3.327.

                         

                        I considered installing Java 7 v. 13 before a restart but in consideration of how my server was running fine with the previous version, I thought it would be best to install Java 7 v10 and postpone the update to v13 until after I get the Admin Console to launch.

                         

                        Then, I restarted the server.

                         

                        Still can't access the start page using localhost:16000

                         

                        The installer application reported that it was successfully insalled, but if I type  fmsadmin -v   into Terminal, it first reports Version 12.0v2 and then a moment later it reports Connection Refused: Server is unavailable.  Then, Error: 9

                         

                        Then, when I use Terminal to see which version of Java I am running, even after installing Java 7 v 10  (which appears properly in the System Preferences)  Terminal still reports:

                        java version "1.6.0_37"

                        Java(TM) SE Runtime Environment (build 1.6.0_37-b06-434-11M3909)

                        Java HotSpot(TM) 64-Bit Server VM (build 20.12-b01-434, mixed mode)

                         

                         

                         

                        Got a call from Taylor Sharpe a few minutes ago.  He gave me the IP for his server, and I was able to access his Start Page, download the JNLP file, and connect to his server -- from mine.   So that is encouraging, in a way.  So I agreed to unstall FMS and restart the server and reinstall FMS ---  again (must be the 6th time since yesterday!)

                        • 9. Re: Admin Server Console and Java 7
                          wimdecorte

                          dburnham wrote:

                           

                           

                           

                          The installer application reported that it was successfully insalled, but if I type  fmsadmin -v   into Terminal, it first reports Version 12.0v2 and then a moment later it reports Connection Refused: Server is unavailable.  Then, Error: 9

                           

                           

                          fmsadmin -v will first report the version of the fmsadmin tool itself, after you provide your credentials it will tell you the version of FMS itself.  A bit confusing but it does not mean that the v3 update didn't work.  v2 seems to be the current version of the admin tool.

                          • 10. Re: Admin Server Console and Java 7
                            BruceHerbach

                            Hi,

                             

                            When you look at John's origina post,  it breaks a single unix command line into two lines.  What you want to do is copy then paste the first line,  hit the space key then copy the second line and paste it on the the line started in the command window.  Once you have the complete line then hit enter.  It should ask for your password and if you have admin level access it will execute the line.

                             

                            I have done a bit of Unix work in the past and still had the same problem.  I had to look closely to realize that the second line was really part of the first line.

                             

                            HTH

                            Bruce

                            • 11. Re: Admin Server Console and Java 7
                              justinc

                              I am having similar Java and FM Server consternation problems.  I recently accepted an update from Mac OS X (running Lion server 10.7.5 now - after all the updates) and that's when the Admin Console stopped working, saying that I needed to install Java.  I have installed/uninstalled Java a few times (I think...they don't make it easy), and I currently (I think) have both Java 6 and Java 7 installed.  The FM documentation about these Java issues imply that you should have both for now, until they can figure out a unified v7 implementation of the console.

                               

                              In addition to that, I wanted to ask/mention the versioning reported by the "fmsadmin" command.  During the updating of OS X mentioned, I also updated FMS.  When it was done, "fmsadmin -v" reported version 12.0v2, and then I got a 10502 error message.  What's that one? 

                               

                              (We have a client that has FMSA 12.03 installed; their "fmsadmin -v" reported 12.0v2, asked for PW/UN, then reported "FM Server version 12.03v (64-bit)...".  So I am guessing that there weren't updates to the fmsadmin tool; that's fine.  But what is the 10502 error that I am getting?  The Internet searches I have done mostly result in foreign language hits.  And the few English hits don't seem to address the error message, just mention it.

                               

                              Thanks,

                              J