5 Replies Latest reply on Jan 20, 2013 8:19 AM by BruceHerbach

    Editing Perform Find Restore not doing expected

    MarkB

      Hi All,

       

      I am trying to edit an existing Preform Find [Restore] to remove the top find requests (see box 1 below). Regardles of which request I have highlighed, the system always removes the bottom request (see box 2 below). In order to edit the request, I must actually delete the script line and start over. I don't recall having this problem in FMPA-11. I'm running in Windows 7 with FMPA-12. Is anyone else having this behavior?

       

      Regards, Mark

       

      Box 1 Box 1.png Box 2 Box 2.png

        • 1. Re: Editing Perform Find [Restore] not doing expected
          Stephen Huston

          I don't have 12 on Windows for testing today, however...

           

          The request you are editing is an AND request which means it is multiple criteria in a single search process, as opposed to and OR request which is more like multiple concurrent searches.

           

          It seems probable that an AND request would need to be rebuilt from scratch fi edited, though I agree that this seems like a bug and unnecessary work if you need to change only one of the criteria.

           

          Does this happen when you are editing an OR search?

          • 2. Re: Editing Perform Find [Restore] not doing expected
            BruceHerbach

            Hi Mark,

             

            I just tried this FileMaker Advanced 12.0v3 Mac and was able to create a script with a two part search (AND), save the script and then go back in and edit both parts of the find with out deleting the scrpt step. 

             

            In trying this, clicking on the line provided the information  for the selected line in the lower portion of the window.  Changing the criteria enabled the "Change" button.  If I didn't make a change only the Remove button was enabled. If I then changed the criteria back to the original value the change button dimmed.  In short FileMaker knew where it started and what had or had not been changed and enabled the buttons to match.

             

            So at least on a Mac it works as expected.

             

            Bruce

            • 3. Re: Editing Perform Find [Restore] not doing expected
              MarkB

              Hi Stephen,

               

              I have no problems with OR searches.  The problem is with AND searches.  There is no problem editing the AND serach and hitting the change button.  It is only when I want to remove one of the AND searches that it always removes the bottom search.  If I want to remove the top search, I have to delete the entire script step and start over.

               

              I went back and tested this in FMPA-11 and the behavior is the same.  So this is nothing new to FMPA-12.  My question is why allow the Remove button to highlight when the top search is selected for removal when it always removes the bottom AND search when it wasn't the search selected.

               

              Mark

              • 4. Re: Editing Perform Find [Restore] not doing expected
                lhoong

                Mark,

                 

                I checked this using FMPA 11v4 Mac, and my results mirror Bruce Herbach's findings - deletes and edits work as expected. Perhaps this is a Windows-specific issue?

                 

                Lee.

                =================

                Binary Assist

                220 Gaines Oak Way

                Suwanee, GA 30024

                Voice: (678) 313-5604

                Internet: lhoong@binaryassist.com

                Website: www.binaryassist.com

                 

                FileMaker Certified Developer

                • 5. Re: Editing Perform Find [Restore] not doing expected
                  BruceHerbach

                  HI,

                   

                  I set up FMPA on a Virtual copy of Windows XP and created a script wth a Perform Find step.  On windows it worked as Mark Described.    Possibly worse.  When I deleted the second or a third  part of the and then tried to edit the remaining item,  it throught that one there was the one it deleted.  So I couldn't update it.  This all worked perfectly on the Mac.  So I think it is a Windows version bug and think it should be reported.

                   

                  Bruce