1 2 3 Previous Next 31 Replies Latest reply on Apr 5, 2013 11:00 AM by jlm

    Can't access FMSA admin console

    dodell

      This morning I'm unable to access the FMSA 11 admin console. I'm running Current Installed Version: 11.0.3.309.

       

      If I try to access the FMSA admin console through the web start page, I get the following error in red. Although the web start page displays correctly. Here's the error in red:

       

      HTTP Status 403 -

       

      FileMaker Server has encountered an error:

      Access to the specified resource () has been forbidden.

       

      If the Server Launch Page is not available, visit the FileMaker Website for more assistance.

       

       

      FileMaker Server 11

       

      If I try to access FMSA through the desktop icon, I get the message that "unable to launch application"

      The following error is displayed in the details tab in red: The FMSA is running and the databases are accessible with FMP client. Any suggestions? At thi point, I have to access the FMSA server to cose the open databses.

       

      <?xml version="1.0" encoding="UTF-8"?>

      <jnlp codebase="http://localhost:16000" href="admin_console_webstart.jnlp" spec="1.5">

      <information>

      <vendor>FileMaker, Inc.</vendor>

      <description>FileMaker Server Admin Console</description>

      <description kind="short">FileMaker Server Admin Console</description>

      <icon href="/images/server_icon.png"/>

      <icon height="32" href="/images/server_icon.png" kind="shortcut" width="32"/>

      <icon href="/images/server_splash_adv.jpg" kind="splash"/>

      <title>FMS11-7Server</title>

      <shortcut>

      <desktop/>

      <menu submenu="FileMaker Server"/>

      </shortcut>

      </information>

      <resources>

      <j2se initial-heap-size="32m" max-heap-size="128m" version="1.5+"/>

      <jar href="admin-client-lib/admin-console-client.jar"/>

      <jar href="admin-client-lib/valuefield-client.jar"/>

      <jar href="admin-client-lib/linksupport-client.jar"/>

      <jar href="admin-client-lib/datechooser-client.jar"/>

      <jar href="admin-client-lib/ulc-jnlp-client.jar"/>

      <jar href="admin-client-lib/ulc-base-trusted.jar"/>

      <jar href="admin-client-lib/ulc-base-client.jar"/>

      <jar href="admin-client-lib/ulc-servlet-client.jar"/>

      <jar href="admin-client-lib/jgraph.jar"/>

      <jar href="admin-client-lib/deployment.jar"/>

      <jar href="admin-client-lib/AppleJavaExtensions.jar"/>

      <jar href="admin-client-lib/http.jar"/>

      <property name="apple.laf.useScreenMenuBar" value="true"/>

      <property name="com.apple.macos.smallTabs" value="true"/>

      <property name="com.filemaker.adminconsole.ui.clients.showError" value="log"/>

      </resources>

      <resources os="Mac OS">

      <jar href="admin-client-lib/quaqua-filechooser-only.jar"/>

      <nativelib href="admin-client-lib/libquaqua.jnilib.jar"/>

      </resources>

      <security>

      <all-permissions/>

      </security>

      <application-desc main-class="com.filemaker.adminconsole.ui.clients.AdminConsoleJnlpLauncher">

      <argument>keep-alive-interval=60</argument>

      <argument>log-level=WARNING</argument>

      <argument>carrier-stream-provider=com.ulcjava.base.shared.TrivialCarrierStreamProvider</argument>

      <argument>url-string=https://localhost:16001/adminconsole.ulc</argument>

      <argument>launchtype=normal</argument>

      <argument>server-language=en</argument>

      <argument>server-timezone=America/Montreal</argument>

      </application-desc>

      </jnlp>



        • 1. Re: Can't access FMSA admin console
          vmeyers

          Hello. We are experiencing the same issue this morning and our configuration seems similar to yours. We are researching and testing, thinking it may have something to do with Java. Sorry, no answers yet.

          Vaughn M

          • 2. Re: Can't access FMSA admin console
            DavidZakary

            Apple has blacklisted part of the current Java version again this morning. Apparently the current version had 2 zero-day security issues. One was patched and the other wasn't. Due to this Apple's automatic updating of security issues was triggered.

             

            This may be causing the problem.

             

            More details here. http://goo.gl/H4MNw

            • 3. Re: Can't access FMSA admin console
              vmeyers

              Thank you David. If this is the issue it would seem that it would be affecting a lot more of us (anyone running FMSA 11 on a Mac) because it is not an issue we can control and must wait for Apple or Oracle to correct it. Did you find a workaround or or you not running FMSA 11 on a Mac?

              • 4. Re: Can't access FMSA admin console
                DavidZakary

                Hasn't been an issue yet - I haven't had to connect to any servers yet.

                 

                One thing that I do - I maintain a copy of a previous OS X installation in Parallels. Once its stable I lock it down and don't update it. Annoying but it works.

                • 5. Re: Can't access FMSA admin console
                  dodell

                  It seems that is probably a Java issue, as I just installed  Java  7 update

                  11 yesterday.  I was installing a development version FMSA 12 and it needed

                  an updated Java version to launch FMSA !2 admin console.

                  The error indicates ³The application has requested a version of JRE (version

                  1.5+) that is not installed.

                   

                  Derek

                  • 6. Re: Can't access FMSA admin console
                    databuzz

                    I'm also experiencing Admin Console issues this morning on some Mac's. I knew something was amiss when everytime I double clicked my Admin Console.app it opened Software Update. Deleting files and downloading new version led to the same result. I'm still on Java 1.6.0_37.

                    • 7. Re: Can't access FMSA admin console
                      jpedmd

                      Yet another user running FMS 11 on OS 10.6.8, this AM (Feb 1) can't run admin console with same error messages.  I'm sure it's related to Apple's Java blacklist of 1/31; the console was running fine 36 hours ago and a server restart was done yesterday around noon - I suspect with software updates. I have a cloned startup drive made 4d ago that I can run from, but would prefer using a workaround if someone comes up with one.

                      • 8. Re: Can't access FMSA admin console
                        OllyGroves

                        Yep, same here, client office, OSX 10.6.8, FM Server 12.3, Java 1.6.0.35 (will try 1.6.0.37 but assume will be same issue).

                         

                        FM Server Admin was left open for few days when I got here, was working happily, then I accidently closed, when tried to re-open. got the "Unable to Launch Application" message.

                         

                        Presume something to do with Java Webstarts never ending security issues.

                         

                        Filemaker Inc, if you're listening, please throw everything at getting an admin console released outside Java ASAP, when it works its great but its always been embarrasingly flakey, in the past six months its become a total deal breaker.

                        • 9. Re: Can't access FMSA admin console
                          dodell

                          Okay thanks.  It seems like we narrowed in on the issue.  I'm running 10.6.8, FMSA Installed Version: 11.0.3.309. and   java version "1.6.0_35" too.  I would consider upgrading the OS to 10.8, but FMSA 11 custom web Publishing won't work on Mountain Lion:  (http://help.filemaker.com/app/answers/detail/a_id/11005/kw/mountain%20lion/related/1).

                           

                          Derek

                          • 10. Re: Can't access FMSA admin console
                            jpedmd

                            Derek, upgrading the OS won't help in any case - Apple has apparently blacklisted Java for at least 10.6 and above.  We'll either need an acceptable Java upgrade, knowledge of how to bypass the blacklist, or revert back to the system state before the 1/31 blacklisting.

                             

                            Agree with others that FM needs to move away from Java for Admin Console and that Apple needs to do a MUCH better job of informing users about what software updates may do, including presenting those with mission critical Java applications an option for continued use after being informed of the risks of doing so.

                            • 11. Re: Can't access FMSA admin console
                              OllyGroves

                              yeah Java 1.6.0.37 doesn't help. I can't upgrade Snow Leopard right now (not mine), I'm going with Terminal commands until get some guidance.

                               

                              below might help...little help sheet I just gave to my client IT Admin guy. To help with basics.

                               

                              ----

                               

                              FILEMAKER 12 SERVER COMMANDS via TERMINAL APP

                               

                              Note: Terminal App will ask FM Server 'Username' & 'Password' to run the command in terminal

                               

                              username: xxxx

                              password: xxxx

                               

                              ---

                              IN TERMINAL APP HELP

                               

                              fmsadmin HELP COMMANDS  = Lists available commands

                              fmsadmin HELP <INSERT_COMMAND> = shows help on specified COMMAND

                              fmsadmin HELP OPTIONS =  lists available options

                               

                              ---

                               

                              USEFUL STATUS COMMANDS

                               

                              fmsadmin LIST FILES  = lists all open/hosted files

                              fmsadmin LIST CLIENTS = list all connected clients

                              fmsadmin STATUS FILE <insert_filename> = show status of that file

                              ---

                               

                              SEND MESSAGE TO ALL CLIENTS

                               

                              fmsadmin SEND -m "I'm going home"

                               

                               

                              Cheers

                               

                              Olly

                              • 12. Re: Can't access FMSA admin console
                                OllyGroves

                                Update:  this is seems a seperate Snow Leopard / Java issue not the Java 7_11 issues currently making news.  Seems Apple Xprotect system nobbled 10.6 java on 31 Jan.

                                 

                                Have a look in you 'Xprotect.meta.plist' (best google for where to find on your system). 

                                 

                                Mine has a min JavaWebComponentVersionMinimum of 1.6.0_37-b06-435 - ie. I don't think that exists yet. the latest is 1.6.0_37-b06-434 & what i've got installed

                                 

                                ---

                                 

                                You can manually hack the Xprotect system - but its not advised as its been locked down for security issues.

                                 

                                http://apple.stackexchange.com/questions/80590/how-can-i-circumvent-xprotect-and-re-enable-java-applets

                                 

                                ---

                                 

                                FYI another client machine on 10.8 server, does let me open Admin console using following url & running 'Start Admin Console'' from there but a desktop applet doesn't allow me to open the console though )    ie. from - http://localhost:16000  

                                 

                                 

                                FMS 12.3 server, OSX 10.8.2, Java 1.7.0_10 (lothed to upgrade Java to latest 1.7.0_11 now as suggestions thats now locked down too?)

                                 

                                 

                                A big old mess, lets hope it all gets sorted out quickly but I won't hold my breath.

                                • 13. Re: Can't access FMSA admin console
                                  dodell

                                  A new version of Java was just released.  Version 7 Update 13 for Mac OSX.  I just installed it an the issue is resolved.

                                   

                                  Derek Odell

                                  • 14. Re: Can't access FMSA admin console
                                    BeatriceBeaubien

                                    Hi Derek,

                                     

                                    Thanks very much for the update.

                                     

                                    Beatrice Beaubien, PhD

                                    i2eye, Toronto, Canada

                                     

                                    FileMaker Business Alliance

                                    FileMaker 12 Certified Developer

                                    Knowledge Translation Certified Professional

                                    1 2 3 Previous Next