2 Replies Latest reply on Feb 5, 2013 9:25 AM by ch0c0halic

    Problems accessing FMSA12 files on server "b" from FMSA12 on server "a"

    Heine

      Strange title, I know ..

       

      I've just upgraded my departments entire setup = three servers, now all running Mac OS 10.7.5 Server and FMSA 12. All machines have dedicated IP-addresses, and my sites are all available on port 80 (if this matters at all).

       

      I have my php (FMStudio Pro) driven sites connecting to the db's and it's working just great, as long as the php on server "a" only talks to the files on server a"", and the php on server "b" only talks to the files on server "b".

       

      However, not everything in life is perfect... I also need for some of the files on server "b" to get data from selected files on server "a". This is becoming a bit of a challenge. I can see the files as TOCs and I can create layouts from these TOCs and access data WITHIN FileMaker.

       

      It should be said that all of the files were on the same server before the upgrade, stored in different folders on the server, and I was able to connect to them by "looking" through the folder like so: /folderName/fileName.fp7 - Everything was working great!

       

      When I want to access the layouts, containing the cross machine files/fields from a browser, I get an error 102 "Field is Missing". I knwo that you can use different paths to point to the files that you want to work with, but I've pretty much tried them all, and nothing seems to work. The FM files are stored on folders on the server, depending on their use, so I'm trying to mirror that path by typing:

       

      fmnet:/hostIP/folderName/fileName.fmp12 (this I've entered manually, and I've checked for typos).

       

      Then I tried to browse my way using the "Remote" button which gives me

       

      fmnet:/domainname/fileName (no file suffix)

       

      I've tried pretty much everything now, but it doesn't help.

       

      As I said, I can see the fields/records from server "a" being displayed on the layouts in the file on server "b", but as soon as I switch to php, things stop working?!?

       

      Anyone ever tried something similar?

       

      Cheers!