0 Replies Latest reply on Mar 7, 2013 11:07 PM by rbmn67

    Server folder and file access

    rbmn67

      Dear forum members,

       

      After a couple of weeks hunting for a solution, I finally post this "please help" question.

      I am installing a FM Server 12 environment on Mac OS X Server, Mountain Lion.

      Since first setup I keep running into rights issues.

      After install everything seems OK: FM Server is fine, apache install and deployment is OK, scheduled backups are fine, user mangement, Open Directory integration, Admin management group etc.Acces to the sample DB works fine, just as Webserver PHP access does. Now for the weird part (at least to me).

      Uploading DB's by means of the java admin console running on either the server or a (mac) workstation keeps gives me the following errormessages:

       

      2013-03-05 10:43:58.665 +0100 Error 755 seafuryserver.local Download of database

      "Klantenbestand.fmp12" by "Admin [192.168.0.122]" failed; exception:

      /Volumes/SeafuryServer HD/Library/FileMaker

      Server/Data/Databases/Seafury/Klantenbestand.fmp12 (No such file or directory).

       

      2013-03-07 16:04:39.564 +0100 Error 670 seafuryserver.local Database "Seafury ERP

      v4.fmp12" could not be uploaded to "filemac:/Volumes/SeafuryServer

      HD/Library/FileMaker Server/Data/Databases/Seafury/". (Could not create the folder:

      /Volumes/SeafuryServer HD/Library/FileMaker Server/Data/Databases/Seafury/ )

       

      2013-03-07 16:04:21.304 +0100 Error 670 seafuryserver.local Database "Seafury ERP

      v4.fmp12" could not be uploaded to "filemac:/Volumes/SeafuryServer

      HD/Library/FileMaker Server/Data/Databases/Seafury/". (/Volumes/SeafuryServer

      HD/Library/FileMaker Server/Data/Databases/Seafury/Seafury ERP v4.fmp12.zip (No such

      file or directory))

       

      This seems to have something to do with OS level access rights. So I checked: folder owner, workgroup, workgroup members, read/write/execute access.

      In a last clueless effort I uninstalled FMS, removed user "fmserver user" and "fmsadmin" with the workgroup manager and reinstalled under root, to make sure there would be no install user rights issues. fmserver user and fmsadmin group are created again, and look good to me. And yes, I can copy files manually to the FMS db-folder, at first leaving users with a read-only DB, after the last install with proper access to the DB. If I copy paste the path filemaker is using for DB storage and try to validate the path, it fails validation.

       

      I need my key user to get setup using the admin console for removing and uploading prototypes without giving her permission to the Library folder.

      In fact, no access to the entire server, preferably ....

       

      Summerized, owner and group settings seem fine, as well as user and group rights and folder ownership, users are member of fmsadmin but I am still missing something.

      We are planning downtime for a complete server clean install but I can't stand not knowing the root cause of this issue.

       

      Any help on finding the root cause would be greatly appreciated.

       

      Many thanks in advance,

      with kind regards,

      Ruud Bouman - van de Vijver.

       

      Update 13-03-2013:

      Solved the issue with an OS X Clean install. Still not sure about the root cause. If any, might be the sequence of setup, always follow the rules setup OS and OS related stuff first, add accounts, groups etc. before installing any 3rd party SW, from an OS pov.....

      Question unanswered but will close it.

      @All viewers: thank you for your interest.

       

      Message was edited by: Ruud Bouman - van de Vijver