PeterWindle

FM 12 file corruption, help needed

Discussion created by PeterWindle on Mar 15, 2013
Latest reply on Mar 15, 2013 by PeterWindle

Hello all,

 

I have a client who has had a weird file corruption where two records out of 12000 have nothing but question marks in the fields.

 

You can search the record ID and it will find the records, but nothing displays in the fields, except a question mark in each field.

 

 

Recovery removes the two records completely and leaves a message saying that the file should not be used moving forward (which is not an option!)

I have tried recovering a recovery and recovering a compressed copy, the message still shows that there are problems with the file after any process I run it through.

 

They will need to continue working with the file, for now, I have retrived the records from a backup and imported them, but I'm fearful that there will be on-going problems with the data, BECAUSE... this is the SECOND time it has happened.

 

NOTE: after the first time, I had actually exported each table as filemaker files and imported them into a recovered clone, which seemed to bring the missing data back in tact. That was only about 6-8 weeks ago.

 

Info: The file resides on server 2008, FM12 server has all the latest updates etc. It shares to mostly PC's on internal network and iPads via WAN (3G)

 

Anyone have any suggestions on how to make this file stable again, so that data does not go missing? My client and I are getting nervous !

 

FileMaker are suggesting to send them the file, but if there are any other suggestions to resolving the issue, I'd very much appreciate any info...

Outcomes