DDoughtie

Why a recovered file still had issues

Discussion created by DDoughtie on Mar 20, 2013
Latest reply on Sep 13, 2013 by jormond

I thought this might be of use for anyone running into the issue where their Verifications are failing on FMS yet the databases tend to stay up (for the most part). I got this message when i tried to determine why files were failing verification after migrating from FMS9 to FMS11. (I used Recovery on the file). " WARNING: problems were detected while recovering the database. The recovered file should NOT be used going forward; copy only the most recent work from it into a backup copy of the original file." This was happening on a .fp7 file that was created with FMP 9 or earlier. When you see a message like "should NOT" you tend to take notice.

 

The problem was FMP 9 didn't see any problem if you use Recovery. FMP 10, 11 and even 12 see the problem but don't give much insight. I finally poured over the recovery log file in Console and found a vague reference to modifying a calculation followed by some cryptic message about not finding a table key. I looked at the calculation and found it used a custom function. I then opened each custom function and found one had gotten truncated with some gobbledy gook. I fixed it and the one calculation that used the CF. Everything now checks out. So, looks like recovery log doesn't have a way to report directly to the fitness of custom functions. It only reports bad calculations, which may or may not use a CF. The sad part is that this file had been edited for years using only FMP 9 and during the last 3 years they constantly fought with data corruption and had to restore from backup or use file recovery (always using 9 so the bigger issue wasn't being reported). Hope someone finds this useful.

Outcomes