6 Replies Latest reply on Mar 28, 2013 9:05 AM by Linda@compu-books.com

    Can't install ODBC Drivers

    Linda@compu-books.com

      I have downloaded MySQL version 10.7 ODBC driver for Mac, AND the FileMaker ODBC driver, but neither will install for me. I get this error:

      "FileMaker ODBC.mpkg" can't be opened because it is from an unidentified developer. Your security preferences allow installation of only apps from the App Store and identified developers.

       

      Can anyone tell me where to change the security settings so I can install these drivers? Can find it!

       

      Please send me your response directly as well as to this lst. Thanks in advance!

      Linda

      -------

      Linda@compu-books.com

      623-217-2167

        • 1. Re: Can't install ODBC Drivers
          taylorsharpe

          You've been bitten by the security bug!  Apple is trying to make things more and more secure and one way they do this is only allowing applications they have reviewed and approved in their app store.  However, misc. utilities like an ODBC driver are not going to ever be found in the app store.  Not even FileMaker is.  So to change your preference, go to System Preferences, select Security & Privacy, and change the "Allow applications downloaded from" to "Anywhere".  That will take care of this.  If after you do the install, you can change it back to "Mac App Store and idnetified developers" for better security, but you'll need to do this for any unidentified app. 

           

          Anywhere.jpg

          1 of 1 people found this helpful
          • 2. Re: Can't install ODBC Drivers
            Linda@compu-books.com

            Thank you Taylor!  I looked there earlier, but it was greyed out, and I overlooked it!  So I got the FM ODBC driver to install, but the SQL ODBC driver still had problems.  Is anyone else having this problem?  We've tried the dmg and the zipped up download and neither will install.  Is there a different version I need to use ODBC with mySQL?

            Screen Shot 2013-03-27 at 4.30.14 PM.png

             

            Linda

            -------

            Linda@compu-books.com

            • 3. Re: Can't install ODBC Drivers
              PSI

              Linda,

               

              for MySQL you need the Open Source Driver: http://www.actualtech.com/product_opensourcedatabases.php

               

              I haven't installed on the newer mac OS just 10.6.8 and it works great.

               

              John Morina

              Pueblo Systems

              1 of 1 people found this helpful
              • 4. Re: Can't install ODBC Drivers
                taylorsharpe

                You won't be able to do this until you change the Security & Privcy to "Anywhere".  If your choice is greyed out, then look down to the left and you'll see a lock.  Click on the lock and it will ask for an administrator's User ID and Password.  Once you unlock it, then you can change the choice to "Anywhere."

                 

                Lock.jpg

                 

                You will also need an admin User ID and Password to install the drivers. 

                • 5. Re: Can't install ODBC Drivers
                  taylorsharpe

                  Mac OS 10.6.8 didn't have this security feature, so it would not have been a problem for you on Snow Leopard.  FileMaker recently released a tech brief saying that technically they will not be supporting 10.6.8 in the future, nor will they be supporting XP.  Obviously they realize that tons of people are still using them and they work with FileMaker 12.  But the writing is on the wall that 10.6.8 is on the way out and so is Windows XP (and Vista!).

                  • 6. Re: Can't install ODBC Drivers
                    Linda@compu-books.com

                    Thank you John!

                     

                    Linda

                    ------

                    Linda Carter

                    www.compu-books.com