8 Replies Latest reply on Apr 1, 2013 4:24 PM by davidmbarwick

    Portal Button Bug - requires two clicks after zoom to 150%

    davidmbarwick

      Using FileMaker Pro Advanced 12.0v3 (Windows version) we have a simple layout with a tab panel that contains a portal. After changing the zoom from 100% to 150% (or setting Preferences to "Enlarge window contents to improve readability") the buttons on the portal rows do nothing on first click except make the portal active. Second click performs the script and it works fine until the zoom is changed. Verified using the Script Debugger.

      Is this a known bug in FileMaker 12 or am I missing something?

        • 1. Re: Portal Button Problem - requires two clicks after zoom to 150%
          taylorsharpe

          I bet that you were actually outside of FileMaker in another app and the first click focuses on FileMaker, but it will not run the script.  Once FileMaker is in focus, the 2nd click runs the script.  Make sure you're in FileMaker when you do the click and the script will run on a single click.  Please verify that this is the situation. 

          • 2. Re: Portal Button Problem - requires two clicks after zoom to 150%
            keywords

            It could also be that it is simply another FileMaker window that is active (eg. manage scripts, data viewer, another data window); this will still have the same apparent effect---the first click focuses on the window in question, the second click activates the button. I've run a test on the settings you describe, David, and don't get the behaviour unless the window is not in focus.

            • 3. Re: Portal Button Problem - requires two clicks after zoom to 150%
              davidmbarwick

              Thank you for your thoughts. FileMaker is in focus.

              It works fine if Preferences to "Enlarge window contents to improve readability" is not checked.

              I can click outside the portal on the tab panel to make sure FileMaker is in focus, then with script debugger on, click any button in the portal and scripts do not run, click a second time and the scripts do run. This was verified on three other machines as well.

              20+ years with FileMaker and I've never seen anything like it!

              • 4. Re: Portal Button Problem - requires two clicks after zoom to 150%
                davidmbarwick

                Thank you for your assistance but the focus does not seem to be the issue. If I put any of the buttons on the tab panel outside the portal they perform the script on first click. Put them back on the portal rows and first click activates the portal but does not perform script, second click performs the script. Very odd. I am clearly missing something.

                • 5. Re: Portal Button Problem - requires two clicks after zoom to 150%
                  stefan_s

                  Hi David,

                   

                   

                  davidmbarwick kirjoitti 1.4.2013 kello 22.57:

                   

                  It works fine if Preferences to "Enlarge window contents to improve readability" is not checked.

                   

                   

                   

                  OK. Firstly, this seems to be a Windows only problem. Could not find the setting you are talking about. As I mainly use Mac OS.

                   

                  So I went to my my Windows 7, under Parallels.

                   

                  Found the setting, checked it.

                   

                  Enlarged the view to 150% and was able to exactly repeat your problem. When the view is 100% one click on the portal row the script does what it should with one click.

                   

                  I would call this a bug and report it to FMI. Unless it is an undocumented feature, of course.

                   

                  It would be helpful to start out the thread by stating what OS you are on, then this might have been discovered sooner.

                   

                  __

                  Stefan Schutt, Mouse Up, Finland

                  (also 20+ years with FMP and a couple of years with FM II)

                  1 of 1 people found this helpful
                  • 6. Re: Portal Button Problem - requires two clicks after zoom to 150%
                    davidmbarwick

                    Hi Stefan,

                     

                    Thank you for verifying this. Yes, it is Windows and I should have mentioned this at the start (was my first post so I'll try to do better next time).

                     

                    Dumb question: How do I report a bug to FMI?

                     

                    Dave

                    • 7. Re: Portal Button Problem - requires two clicks after zoom to 150%
                      taylorsharpe

                      David... glad to see you make your first post and hope you'll get involved around here. 

                       

                      I'm sure there is some official way to do it.  I've known some of their systems engineers and reported it directly to them.  But I think the normal way is to open FileMaker, go to the HELP pull down menu and select "Provide FileMaker Feedback".  This is for more than just bugs... if you have a feature suggestion or something that might be useful in a future version, this is a great place to provide feedback.  Give that a try and maybe someone will speak up if there is some official way to log a bug with FileMaker other than this feedback method. 

                      • 8. Re: Portal Button Problem - requires two clicks after zoom to 150%
                        davidmbarwick

                        Taylor,

                        Problem reported as you suggested. And, referenced this discussion. Also updated original post with operating system (Windows) per Stefan's suggestion.

                        Thank you.