1 Reply Latest reply on Apr 16, 2013 5:20 AM by Paul Jansen

    Weird FileMaker 12 Printing Problem (SOLVED)

    ChrisVanBuren

      Hi - below is a post I never posted because I have found a workaround but I thought I would share it in case someone else has the problem.

       

      -Read the post to understand the problem

      -The workaround is to i) put a new text object on the layout ii) copy the desired text to notepad (a plain text editor) iii) copy it back from notepad into the new text object. Note that I say "put a new text object" on the layout because that is what I did. I am not sure that is actually necessary.

       

      So the answer is the the text itself is somehow corrupt or non printing. How? I have no idea. Note that I am not sure how many layouts are affected in the file. My suspicion is that all of them are but I don't know this. Definitely several layouts are affected.

       

      Cheers,

       

      Chris Van Buren

       

       

       

      Hi All,

       

      Ready for a tough one? Here it is:

       

      -Customer has 48 file database system on Windows in a Citrix environment which was, until Monday, running fine on FM11. Now on FileMaker 12, there is a weird printing problem.

       

      -Mostly printing seems OK. I have complaints on printing on only one file (ironically called "Customer Complaints.fmp12")

       

      -On Customer Complaints.fmp12 they are trying to do the simplest thing possible. They are trying to print from a layout called "DWSP". This layout is the simplest layout in the world, it contains only one large text block on it. No fields. No merge fields. Facts about this layout:

      i) The text block does not have "Hide when printing" ticked

      ii) There is only one part which is a body. The body has no special options ticked.

       

      When

       

      -When DWSP is printed to a real printer, you get a flash but nothing comes out of the printer. Nothing appears on the printer queue. This might be incorrect as they can't see the print job arrive at the queue. I have asked them to pause the queue (to see if the job arrives) but this is impossible as MS Windows will not allow a network print queue to be paused (no pause option).

       

      -When DWSP is printed to the Microsoft XPS Document writer (and Microsoft competitor to pdf) it prints fine. The resulting xps document contains the correct text.

       

      -When a new layout is created in Customer Complaints.fmp12 and some text is put on it, it prints just fine. It is just bizarre. There is no real difference between the DWSP layout and the new layout. Just the amount of text on the layout.

       

      -Font is Arial 10 point. There are no symbols or anything special in the text at all.

       

      -Creating on new text block on layout DWSP and copying in the correct text makes no difference (still doesn't print).

       

      -One thing noted, which may be a red herring, is that when I print to a local test printer on pause, I get a page count of N/A on the print jobs.

       

      -File passes Recover with no errors.

       

      Any suggestions? It is a real problem to my client and there seems to be no solution. They are working round at the moment by printing to a PDF writer and then printing from that but they shouldn't have to do that.

       

      Cheers,

       

      Chris Van Buren

      ---------------------------------------------------------

      e: chris@zeropointdata.com

      t: +44 (0)1291 689966

      www.zeropointdata.com

       

       

      Abbey Lodge, Tintern, CHEPSTOW, NP16 6SF, UK

      ---------------------------------------------------------