6 Replies Latest reply on Apr 2, 2017 4:33 AM by Storganise

    Admin Server process has terminated abnormally

    user19840

      Hi,

       

      I've read through various other discussions to help with my issue. I've reinstalled multiple times, followed the Getting Started guide and checked the pre-requisites. I've checked that IIS is installed and running (CGI too). I've used "netstat -ano|grep 16000" to make sure the port is available. I see port 5003 is in use by the actual server. I've turned off the firewall completely. Anti-virus is disabled.

       

      However the Admin server will still not start. I've checked the Windows log and the C:Program FilesFileMakerFileMaker ServerLogsEvent.log. Attached is the log from a brand new install. The last line "Admin Server process has terminated abnormally." repeats numerous times with nothing in between every time I run "fmsadmin restart adminserver".

       

      FileMaker Server 12.0v3 x64 (09-20-2012)...

      Microsoft Windows 7 x64 (6.1.7601, Service Pack 1), with 8 logical processor core(s)

       

      My next step is to try the install on a new install of a Virtual Windows 2008 Server to see if it's just my local development machine with the issue.

       

       

      Any help is greatly appreciated!

       

      Thanks!

        • 1. Re: Admin Server process has terminated abnormally
          taylorsharpe

          Why not install FileMaker Server 12.0v4 since it is the latest version.  Also make sure you have the latest version of Java 7 since that is what FileMaker Server12.0v4 uses (previous to this version, it was using Java 6). 

           

          I will also note that a real server platform like Windows 2008 Server, is a better OS for services like FileMaker Server than Windows 7. Windows 7 is optmized for applications and not services. 

          1 of 1 people found this helpful
          • 2. Re: Admin Server process has terminated abnormally
            user19840

            Hmm. I thought I had the latest one already. Just checked the download file is named fms_12.0.4.405.exe which I assumed was the latest version.

             

            My java is Version 7 Update 17 (build 1.7.0_17-b01). Maybe that's the conflict.

             

            This was just a local development environment, since I don't have a Windows Server 2008 instance readily available. We do plan on installing it on Windows Server 2008. But like I said, I'm working on installing a virtual server on my local to test it out too.

             

            Thanks for the advice. I will try your suggestions and update this thread with my results.

             

            Again, thanks.

            • 3. Re: Admin Server process has terminated abnormally
              user19840

              UPDATE

               

              The Event.log reports FileMaker Server 12.0v3 x64 (09-20-2012) for FileMaker Server 12.0v4.

               

              Additionally, the installer installs it's own version of Java 7 Update 17. I had a second installation of Java 7 Update 21 (the latest) and this may have caused a conflict.

               

              I temporarily set up a Windows Server 2008 R2 VM and FMS installed perfectly the first time.

               

              Everything seems to be running as expected.

              • 4. Re: Admin Server process has terminated abnormally
                ecshelp

                I noticed this last week too when I updated my Win 2008 R2 Server from Java 7 Update 17 to Java 7 Update 21 getting the Admin Server process has terminated abnormally.  (I'm running FMS 12v4.)  I finally uninstalled Java 7 Update 21 and reinstall Java 7 Update 17 and haven't seen FMS crash since then.  If FileMaker Server 12.0v4 installs its own version of Java, I didn't see it listed in Programs & Features, so how would we be able to prevent FMS from installing its own version of Java (that cannot seem to be updated) when Oracle releases an update?

                • 5. Re: Admin Server process has terminated abnormally
                  Storganise

                  Hi All,

                   

                  I would like to re-visit this as it seems to be happening to me for reasons I can't work out.

                   

                  Windows Server 2012 R2 Filemaker Server 15.0.3.308

                   

                  Every 2min 32secs this is coming up in the event log

                  2017-03-31 14:35:35.561 +0100Error701VSMALLON07Admin Server process has terminated abnormally.
                  2017-03-31 14:35:35.607 +0100Information703VSMALLON07Starting Admin Server process...
                  2017-03-31 14:35:35.670 +0100Error701VSMALLON07Admin Server process has terminated abnormally.

                   

                  I can't access the ServerAdmin console using Localhost either remotely or locally.

                   

                  I did a complete uninstall of all window updates back to a time before this became a problem. Uninstalled Java, IIS, Microsoft Visual C++, in fact I uninstalled everything from the Server, then removed the Filemaker installation, renamed the old folder so it wouldn't associate with it, and reinstalled Filemaker Server.

                   

                  Still getting this issue, and it's becoming a real bore. Anyone got any more ideas?

                   

                  James

                  • 6. Re: Admin Server process has terminated abnormally
                    Storganise

                    An update to this...

                     

                    It IS a Java issue. I uninstalled everything again, reinstalled, and we are up and running. Importantly, do not install the latest version of Java. I was trying to get MirrorSync installed as well, but the .jar file was causing issues. Eventually I convinced it to open using the Filemaker Install of Java, and everything is now back to normal and behaving how it should do.

                     

                    Phew!

                     

                    James