8 Replies Latest reply on May 30, 2013 8:40 AM by smclennan

    Value Lists not displaying correctly

    smclennan

      I am trying to display value lists in portals but when selected they are empty! I am using a "values from field" value list and would like to display only values from the second field. Nothing displays. If I display only values from the first field, that works. If I display both fields, that works. But if I select "show values only from second field" nothing displays. What am I doing wrong? What is really frustrating is that I'm sure it has worked in the past but I don't know what I've done to make it not work any more!

        • 1. Re: Value Lists not displaying correctly
          LyndsayHowarth

          There are a couple of reasons this might happen.

           

          Are you showing all values or only related values?

          Have you chosen the base table or a specific relationship to filter the values and therefore are you attempting to show values when that relationship has not been satisfied?

           

          - Lyndsay

          • 2. Re: Value Lists not displaying correctly
            smclennan

            Thanks Lyndsay,

             

            I am showing all values.

            I have chosen the base table.

            It is "working" now if I include an arrow to show and hide the list, in one of my portals. In the other, I don't need the arrow, but I have to show both fields in order to get the list to show.

             

            Susan

            • 3. Re: Value Lists not displaying correctly
              debi

              Susan,

               

              Are you using v12? I encountered an issue with a two-part (number ID plus text value) value list in a portal when converting a solution to v12. Check your "Data Formatting" section of the Data tab in the Inspector; make sure it is "As Entered" instead of a specific number (or other non-text format).

               

              Does that help?

               

              Debi Rubel
              FullCity Consulting

              • 4. Re: Value Lists not displaying correctly
                smclennan

                Debi,

                 

                I am using V12 and, like you, I am also trying to display a text value instead of it's numeric ID. I changed to "as entered" and now nothing is displaying!!! So I changed it back to "general" and still nothing displays, when it was displaying before! It seems to randomly work or not! Thankfully it doesn't hinder the data entry, but you have to know the numeric codes which is not practical in this application.

                 

                Susan

                • 5. Re: Value Lists not displaying correctly
                  debi

                  Susan,

                   

                  If I recall correctly, I was entering foreign key values into a number field, using a popup (not a drop-down) value list. Maybe General was the correct setting - I think the key was that I had to change it from decimal or boolean or something else along those lines. What kind of control are you using (drop vs pop)? What type (text, number) of field are you entering into?

                   

                  Debi Rubel
                  FullCity Consulting

                  1 of 1 people found this helpful
                  • 6. Re: Value Lists not displaying correctly
                    smclennan

                    Debi,

                    I am using drop-down lists, which is the only practicle option in my case. I just played with popup and it works fine so it seems that it is only the drop-down that isn't working. A Filemaker 12 problem?

                    Susan

                    • 7. Re: Value Lists not displaying correctly
                      debi

                      Susan,

                       

                      What is the field type for the field formatted with the value list? The problem may be that it is a number field trying to display text; does it work if changed to text?

                       

                      It sounds as though that is a key field. Changing the type of a key field from number to text should not break a relationship, but may cause other issues to pay attention to, especially as related to finding and sorting.

                       

                      Also - are you on the most current version? I don't remember anything specific in the updates related to that, but it could be worth checking.

                       

                      ~debi

                      • 8. Re: Value Lists not displaying correctly
                        smclennan

                        Debi,

                        Switching to pop-up menu has solved the problem! Still not sure why it won't work with a drop down list, but I'm very happy with how it works now. Thanks for your help.

                        Susan