4 Replies Latest reply on Jun 7, 2013 7:28 AM by tony.dhoop@telenet.be

    Numeric data input problem due to keyboard layout (period or komma)

    tony.dhoop@telenet.be

      In Belgium (also France) we use AZERTY keyboard.

      The rest of the world uses Qwerty.

       

      Under the numeric keyboard,

      in AZERTY there is a komma

      in QwERTY there is a period.

       

      This affects data imput in an important way :

       

      Entering 1,5 (one and a half) with both keyboards you get :

      in AZERTY : 15 (the komma is not recognised in a numeric field, so is ignored)

      in QWERTY : 1,5 (correct value of "one and a half")

       

      In Azerty, to get the correct value, you have to go to the left side of the keyboard to get the period.

      VERY unfortunate, inefficient, unhandy and most of all, subject to mistakes (since many users forget this rule, so enter false data).

       

      Very strangely, when entering the "," under the numeric pad in AZERTY, you see on the screen a "." ... but it is not recognised as a decimal seperator.

       

      To get around this problem, I'm using a script trigger :

       

      Set Variable [$input ; Value:input::Numeric_Input]

      If [PatternCount ($input ; “.” ) = 1]

      Set Field [input::Numeric_Input ; Substitute ($input ; “.”; “,”)]

      End If

       

      But you'll agree to have this set up for ALL numeric fields is quite inefficient...

      there must be a more system wide solution possible for this, I hope ?

       

      thanks

      Tony

        • 1. Re: Numeric data input problem due to keyboard layout (period or komma)
          stefan_s

          Hi Tony,

           

           

          You could use an Auto-enter calculation.

           

          Substitute(Self; "."; ",")

           

          This should take care of the situation. And yes, "Self" does work. Came in version 10, I think.

           

           

          HTH

           

          __

          Stefan Schutt, Mouse Up, Finland

           

          tony.dhoop@telenet.be kirjoitti 7.6.2013 kello 10.36:

           

           

          created by tony.dhoop@telenet.be in Advanced Discussion - View the full discussion

          In Belgium (also France) we use AZERTY keyboard.

           

          The rest of the world uses Qwerty.

           

           

          Under the numeric keyboard,

           

          in AZERTY there is a komma

           

          in QwERTY there is a period.

           

           

          This affects data imput in an important way :

           

           

          Entering 1,5 (one and a half) with both keyboards you get :

           

          in AZERTY : 15 (the komma is not recognised in a numeric field, so is ignored)

           

          in QWERTY : 1,5 (correct value of "one and a half")

           

           

          In Azerty, to get the correct value, you have to go to the left side of the keyboard to get the period.

           

          VERY unfortunate, inefficient, unhandy and most of all, subject to mistakes (since many users forget this rule, so enter false data).

           

           

          Very strangely, when entering the "," under the numeric pad in AZERTY, you see on the screen a "." ... but it is not recognised as a decimal seperator.

           

           

          To get around this problem, I'm using a script trigger :

           

           

          Set Variable $input ; Value:input::Numeric_Input

           

          If

           

          Set Field input::Numeric_Input ; Substitute ($input ; “.”; “,”)

           

          End If

           

           

          But you'll agree to have this set up for ALL numeric fields is quite inefficient...

           

          there must be a more system wide solution possible for this, I hope ?

           

           

          thanks

           

          Tony

           

          Reply to this message by replying to this email -or- go to the message on FileMaker Technical Network

          Start a new discussion in Advanced Discussion by email or at FileMaker Technical Network

          Manage your email preferences.

           

          FileMaker Developer Conference 2013 • San Diego, California • August 12-15 • www.filemaker.com/devcon

           

          • 2. Re: Numeric data input problem due to keyboard layout (period or komma)
            maxperts

            Hi Tony,

             

            windows or mac ? I found that the AZERTY / QWERTY keyboard itself does have impact on the numeric ',' but in combination with the region you are in.

            On a mac you can choose the belgium azerty keyboard which will give you an ',' when you punch the numeric '.' key. The us qwerty keyboard results in your unwanted '.' input.

            I did test my finding first, since I thought it also had to do with the region choice.

            Btw: I also wrote a script like you have first but I found out that filemaker itself does something to the field-data according to your system region settings. My script kept switching the '.' and the ',' back and forth.

            keys_regions_numeric.png

            So check if there is a regional azert keyboard available for your users.

             

            Hope this helps !

             

            with regards,

             

            Arjen van der Ree

            • 3. Re: Numeric data input problem due to keyboard layout (period or komma)

              Tony,

               

              I assume it's not a matter of the keyboard.

              Fiddling around with the input data is not a solution.

               

              With what country settings was the file created? System settings at this time are relevant.

              Please note: FileMaker files inherit the locale settings from the machine they are created on.

               

              Check your system for the proper belgian settings. Then make a clone of your file and try this.

              It should work as expected.

               

              Winfried

              • 4. Re: Numeric data input problem due to keyboard layout (period or komma)
                tony.dhoop@telenet.be

                Thanks all with the help.

                Your suggestions brought me to the correct solution :

                On the control panel (Windows) it's possible to select keyboard "Belgian (period)" or "Belgian (komma)".

                 

                Belgian (period) solves the described issue.

                 

                Thanks !

                Tony