4 Replies Latest reply on Jun 19, 2013 1:27 PM by brandy.hamblet

    Error while trying to sync

    brandy.hamblet

      Hello,

       

      I am putting together a set of sample/test databases to teach myself how to create a sync solution between a hosted FileMaker 11 database and a deployed database on an iPad in FM Go 11. When I run what I have so far on the iPad, I get error 101 on the highlighted script step below, and I can't figure out why. The rest of the process runs fine, and it updates the records that need to be updated. Any ideas?Screen shot 2013-06-18 at 10.03.06 PM.png

        • 1. Re: Error while trying to sync
          Vaughan

          FMP7Script://~/TestConnectorDatabase.fp7

           

          I'd get rid of the ~/ in the url.

          • 2. Re: Error while trying to sync
            brandy.hamblet

            I just tried that, but now it's not opening the TestConnectorDatabase, but it doesn't give me any kind of error that it's not opening.

             

            EDIT:  Just figured out why I'm getting that error.  It's not because the connector file isn't opening properly.  It's because the connector file has a script that's set to run on open, and the error is from the last step in that script.  All fixed now.

            • 3. Re: Error while trying to sync
              mikebeargie

              I'm not sure why Vaughan is telling you to get rid of the tilde. Could he maybe explain more?

               

              Here's a guide on using the FMP7SCRIPT:// protocol:

              http://help.filemaker.com/app/answers/detail/a_id/7786/~/opening-files-using-the-fmp7-script-protocol-with-filemaker-go

               

              This says to use the tilde in the URL for opening a local file. $ is for a hibernated file, then IP address for a remote file.

               

              Some questions to help troubleshoot this:

               

              1) Is it successfully creating TestConnectorDatabase.fp7 in your filemaker documents folder?

               

              2) Is there any other instance of TestConnectorDatabase.fp7 running while trying to run this script?

               

              101 is normally the error returned at the end of a loop when you have "Go To Next Record" specified and the loop is on the last record. It's odd that it would be returned related to this script step.

              • 4. Re: Error while trying to sync
                brandy.hamblet

                101 is normally the error returned at the end of a loop when you have "Go To Next Record" specified and the loop is on the last record. It's odd that it would be returned related to this script step.

                I figured it out just a moment ago.  This is exactly why that error was coming up.  I had set the connector file up to run a script upon opening that find the records in the deployed file to be updated and then loop through the corresponding records in the hosted database.  The very last script step in the current process is to go to the next record before it ends the loop.