AnsweredAssumed Answered

File Path Problem: Snow Leopard vs. Mt. Lion?

Question asked by ecologist on Jul 7, 2013
Latest reply on Jul 8, 2013 by ecologist

I  am using Mac OS Snow Leopard OS 10.6.8 and my partner is using Mountain Lion OS 10.8.4. I've attached a document (or other file) indexing FM solution where the user:

 

1) selects a file

2) an applescript then opens the file

3) the user can then rename the file, creating a new record in an FM database

4) an applescript then renames the file

5) the file path is extracted and placed into an FM text field either (depending on the file path syntax) via

          a. an applescript that copies it to the clipboard with FM then pasting it into the field, or

          b. a Get (DesktopPath) script

6) scripts then parse the text field and edit the file path to the correct syntax for FM and Mac

7) a calculation field that displays as a container is defined as = the text field

 

Viola! The file can now be opened from within its database record by clicking on the calculation field that displays as a container.

 

This works flawlessly on my Mac running Snow Leopard. It does not work on my partner's Mac running Mountain Lion. The exact same path(s) to file(s) in the same relative position on the computer does not allow FM to find that file so it can be opened from the calculation-container field. Is this a syntax problem in the file path in Mt. Lion? I've tried hand editing the file path in various ways but not found anything that works. Any ideas on what is wrong and how it can be corrected?

 

I'vr tested this it under various scenarios on both the Mac running Snow Leopard and the computer running Lion. It works perfectly on the Snow Leopard computer, but not on the computer running Lion. The different scenarios were:

1) file on desktop

2) file in folder on desktop

3) file in folder in Volume

4) file in Users (i.e., the house icon Mac's show in the finder)

 

Same result for all. Fully functional under SN, but completely dysfunctional under Mt. Lion.

 

Just to be clear, this is with the FM solution installed separately on both computers and testing with files located on that particilar computer.

 

Is the problem something about Mt. Lion or is there something peculiar about my partner's computer? Thanks in advance for any insights or help anyone can provide.

Attachments

Outcomes