1 2 Previous Next 21 Replies Latest reply on Apr 30, 2015 3:15 PM by aeperrisyn

    Pop-up menu "type-ahead" not working on Windows

    flybynight

      I have a FM12 solution that uses a value list on the JobTicket table in the client foreign key field. I'm populating that with a value list that is set to the contact primary key, also/only showing a field that concatenates Company & ClientName. So, the user grabs that pop-up and sees a big list of all the contacts. The user never sees the ID numbers.

       

      This list is rather long (~2500 records).

      On any of our Macs, the user can click into the field to get the pop-up menu, and type a few letters to jump to that spot in the alphabetical list. This at least gets them close, so they can pick the client they want.

      On any of our Windows computers, typing does nothing. So, the user has to either scroll (painfully slow) or use the arrow to move down the list (not quite as painful).

       

      Is this expected behavior, or am I missing something?

       

      Thanks,

      -Shawn

        • 1. Re: Pop-up menu "type-ahead" not working on Windows
          jbante

          With a list of more than a few dozen items, a pop-up menu or drop-down list is not a great user interface even when it does work. Have you considered using a scripted routine that opens a new window on a list view layout that users can filter and choose from instead?

          • 2. Re: Pop-up menu "type-ahead" not working on Windows
            flybynight

            I may have to do that, but on the Mac (or even on the iPad) it seems to work just fine. It's served from FMServer, and speed seems very responsive. For now there are other ways to make a new JobTicket from within the customer window that will set that automatically. But if the user are doing a new JobTicket without first going to the customer area, then they can choose from the BigOl'List™ of contacts.

             

            Just looking for confirmation on if it should work the same on Mac and Windows...?

             

            Thanks!

            -Shawn

            • 3. Re: Pop-up menu "type-ahead" not working on Windows
              flybynight

              I've checked this out with a couple of other pop-up menus I have with much smaller value lists (2-10 choices) and on Windows typing does not select / highlight an item in the menu like it does on the Mac.

               

              Can someone tell me if this is a bug, or expected behavior?

               

              Thanks!

              -Shawn

              • 4. Re: Pop-up menu "type-ahead" not working on Windows
                flybynight

                Sorry for the bump…

                But I'm really hoping that someone has an answer on this one. For a field set as a pop-up menu using a value list (even a short one), on the Mac, after you click into it to get the pop-up, you can type a few letters and the focus on the list will go to that spot in the alpha listing. On Windows, you do the same thing and nothing happens when you type.

                 

                Can someone else confirm this behavior? Is this expected? Should I submit it as a bug?

                 

                Thanks!

                -Shawn

                • 5. Re: Pop-up menu "type-ahead" not working on Windows
                  databuzz

                  Hi Shawn,

                   

                  I can confirm that is how it currently works in FileMaker Pro v12.0v4 on Windows - I would recommend that you submit a feature request with FileMaker Inc for Windows support for type ahead with pop-up menus. I agree though with jbante that it's not a great solution for long lists on either platform, and that other methods such as a popup window with filtered portals etc are a better solution for long lists.

                   

                  HTH,

                  Andrew

                   

                  FileMaker 12/11/10/9/8 Certified Developer

                  Databuzz

                  - - - - - - - - - - - - - - - - -

                  Phone: +61 2 9484 6565

                  Mobile: +61 418 468 103

                  Email: andrew@databuzz.com.au

                  http://www.databuzz.com.au

                  • 6. Re: Pop-up menu "type-ahead" not working on Windows
                    flybynight

                    We could debate if something is or is not a good way to do accomplish a goal, but it seems to work fine for my purposes. And even on short lists, it is certainly handy to just type to desired selection and hit the return key, like you can on the Mac.

                    …but that's not what this post is about.

                     

                    This seems to me like something that should work the same, regardless of which platform you are using (Windows or Mac). I have submitted it as a feature request, but to me it seems more like a bug than a missing feature. I didn't see a form for submitting a bug… it just mentioned the forums. Is there an official avenue for submitting a bug?

                     

                    Thanks for all the input!

                    -Shawn

                    • 7. Re: Pop-up menu "type-ahead" not working on Windows
                      BillisSaved

                      Hey flybynight,

                       

                      I imagine you've already found your answer, but I thought I'd reply just in case you haven't. I have a list of about 40 companies associated with a drop-down list and I have both the "Include arrow to show and hide the list" and the "auto-complete using value list" properties enabled. If I type the first few characters into the field and then click the arrow to display the list, it is filtered by the characters I entered. I'm using FileMaker Pro 12 Advanced 12.0v4 and this works on both Mountian Lion 10.8.4 and Windows 7. Hope this helps. Have a great day!

                       

                      God bless,

                      Bill

                      • 8. Re: Pop-up menu "type-ahead" not working on Windows
                        flybynight

                        Actually, I put in a work-around where the users go to the customer first and click a button to create a ticket, thus grabbing the ID # and setting it to client foreign key field in the JobTicket record. Other than that, I've had bigger fish to fry, and the users like the work-around, so I've ignored it for now.

                         

                        As for your solution, I'm not actually having any issues with drop-down lists. They work as expected. This one is a pop-up menu. I didn't use a drop-down for this one because my value list uses a 2nd field and showing only those values. When you are finished making your selction, the pop-up will display the 2nd field value, but the drop-down will show the first… in this case an ID # that will mean nothing to the end user.

                         

                        I know there are methods of putting a field on top of or behind the list field to show the value you want, but I haven't played with that yet.

                         

                        Thanks!

                        -Shawn

                        • 9. Re: Pop-up menu "type-ahead" not working on Windows

                          Hi Shawn,

                           

                          I feel your pain.

                           

                          https://fmdev.filemaker.com/message/145986#145986

                           

                           

                          I am sorry to say that no, FMI has not yet addressed this issue.  I am also sorry that you did not receive a good response here ... you deserve (as we all do) to get answers.  It hurts us all a great deal when we are stonewalled this way.

                           

                          I would have tested and responded if I had seen this thread and if I had access to a Windows system to test but I do not (at present) have a Windows system.  I am embarrassed (on behalf of FMI and this community) that it took so long for you to get an answer which isn't an answer at all.  We need to help each other and other developers on windows should have taken the time to test and respond to you.

                          • 10. Re: Pop-up menu "type-ahead" not working on Windows
                            flybynight

                            LaRetta,

                            Thanks for the comment. After 8 months, I had forgotten about this issue. I ended up making a work-around that involved a drop-down list for the type-ahead functionality, with the related 2nd field (the info the user selects) on top of it, not allowing entry. That field hides the foreign ID that is left after the user makes their selection. It's not ideal, because it leaves the ID exposed for brief moments. Not that it's a security issue, just looks sloppy, like you are seeing behind the curtain. Exposed IDs are a pet peeve of mine.

                             

                            Anyway, this was one of the few times I was frustrated when coming here. TechNet is normally extremely helpful. I realize that people were trying to be helpful by suggesting other UX design options, but it came off as ignoring the issue and attacking my design choice. Right or wrong, that wasn't the issue at hand.

                             

                            Also, I don't remember if I ever found the answer to: what is the proper channel to submit a bug?

                             

                            Thanks!

                            -Shawn

                            • 11. Re: Pop-up menu "type-ahead" not working on Windows

                              Proper channel to submit a bug is the link I provided ... Report An Issue.  :-)

                               

                              Yes, I understand how it felt like the issue wasn't being addressed.  Offering alternatives was their attempt to help and it is always appreciated but nobody on Windows stepped up and confirmed the issue or helped pin it down or suggested you submit a bug report (not the same as a feature request). 

                               

                              In our case, where this issue came to light, the User is on table layout (yes please don't bite my head off for using table layouts; I normally don't but we need it in this instance).  Because it is table layout, we cannot put a second copy of same field on the layout (table view only allows one copy of same field) so the ID displays and they have no idea what it represents when viewing.  Our list isn't very long either but it should jump ... pop-up menus used to jump on Windows!  If FMI says they can't make it work any more then we can accept that ... just tell us.

                               

                              I too dislike exposing the ID, Shawn, and I will not use drop-down list when pop-up menus are designed for the purpose. 

                              • 12. Re: Pop-up menu "type-ahead" not working on Windows
                                aeperrisyn

                                So...I have this exact same problem. We've had an all Mac interface for the past 3 years and no issue on a popup menu selecting a vendor on a product by being able to both scroll the list and select to a section of the list by hitting a letter. We recently added a PC to the database and now they can not do this. So my questions are 2 fold:

                                 

                                1) Is there a fix to this? I agree with the original poster, why would it not work the same on a PC as a Mac? We love the functionality and would prefer to keep it the same.

                                 

                                2) If my only option is to write a script, can I get some help on this? I know how to make a new script and pull up the vendor layout, but I am a little confused how to now make that field be populated with a vendor from a list that is appearing in a 2nd window?

                                 

                                Please and Thank You

                                Ann

                                • 13. Re: Pop-up menu "type-ahead" not working on Windows

                                  I am using Windows 8.1 and 12 Advanced, just for your!

                                   

                                  I tried a fresh file of 95 records and created the popper with typeahead built in.

                                   

                                  Works just fine local on a Toshiba. Type a letter and go to the first instance...

                                   

                                  This isn't server as asked for but best I got right this instance.

                                  • 14. Re: Pop-up menu "type-ahead" not working on Windows

                                    It works for me on Windows 8.1 and 12A, 13, and...well, I can't mention that one.

                                     

                                    I ain't using Server at the moment but I think it worked when I was.

                                     

                                    Could plugins be interferring?

                                    1 2 Previous Next