AnsweredAssumed Answered

FMServer Advanced 11.0.4.404 on Snow Leopard Server not configurable

Question asked by wallrodt on Jul 26, 2013
Latest reply on Jul 29, 2013 by wallrodt

Hello,

 

I had FileMaker Server Advanced from the 11.0.4.404 installer running on my 10.6.8 x-serve happily for some time. IWP worked, I could configure the server through the java interface, all was well.


Then a couple of weeks ago the IWP stopped working. The xml was still working and my web databases were still getting data and I could connect via FileMaker Pro 11 just fine.

 

Then a few days ago the xml stopped working so all of my web databases went down. I could still connect to the hosted databases vial FileMaker Pro. I could access the server's main web page but could not access port 16000 or use the java app to control the server.

 

I tried uninstalling and reinstalling the server. The deployment assistant wouldn't work. Port 16000 is never open. I can use FileMaker Pro to open the sample database but can't configure the server.

 

I looked at my Apache configuration file and saw the lines at the bottom that the installer adds:

 

#FMI_Configuration_V1

Include '/Library/FileMaker Server/Admin/admin-helper/WEB-INF/conf/fmi-test.conf'

#FMI_Configuration_V1

Include '/Library/FileMaker Server/Admin/admin-helper/WEB-INF/conf/fm-server-status.conf'

#FMI_Configuration_V1

Include '/Library/FileMaker Server/Admin/admin-helper/WEB-INF/conf/mod_jk.conf'

#FMI_Configuration_V1

Include '/Library/FileMaker Server/Web Publishing/publishing-engine/php/snow leopard/httpd.conf.php'

 

but those files aren't found and they throw off Apache. The only things in the /Library/FileMaker Server/Admin/admin-helper/WEB-INF/conf/ folder are:

log4j.template, managerconfig.xml, wpe_workerconfig.xml, and ws_workerconfig.xml.

 

I looked in a backup that I made a while ago and that folder has 10 items.

 

While trying to troubleshoot this I have tried replacing the Apache config file with a fresh copy, uninstalling the 11.0.4.404 version of FMPServer and installing the full download of the 11.0.5 version, installing the 10.6.8 combined update for the server, and nothing seems to get me through the deployment phase of the install.

 

I would appreciate any suggestions.

Outcomes