3 Replies Latest reply on Jul 30, 2013 11:25 AM by heuristron

    Portal row button missing

    heuristron

      I have a portal on layout with three rows showing. Each row contains a pair of fields and one button set to "Delete portal row". After I add and enter data in the fourth portal row, I noticed that the button disappears altogether on the fourth and all subsequent rows. All input fields on all portal rows appear normal.

       

      All tables belong to the same local file. The relationship of the portal is one child table related to the layout table via IDs with "Allow creation of related records…" turned OFF. The objects on the portal row are smaller than the generous 39 pt row height and do not overlap portal boundaries. The button is located well within the portal row. The portal height is set to a uniform value of (row height x rows showing). The portal is located within 20 pixels of the bottom of the body part. The portal setup does have "Allow deletion of portal records" turned on and Sorting set to one of the portal row fields. The portal and all objects contained within are anchored identically (top & left). All newly created portal records are committed, so there is no latency. No layout objects are locked. No hidden objects are within or behind the portal. Built-in theme was used to create all layout objects.

       

      Buttons for up to 20 portal rows I tested on FileMaker 12.0v4 Advanced on iMac were visible for every row and all functioned correctly. I cannot understand why the first three portal rows display the button correctly in FM Go 12.0.7 on iPad, but the button is missing on subsequent rows. This seems to be a situation unique to FM Go 12.

       

      Has anyone encountered this problem? If so, did you find an answer to solve the issue?

      I'm open to any suggestions, workarounds.

       

      Heuristron

        • 1. Re: Portal row button missing
          LyndsayHowarth

          If you scroll to... or select row 4, does this change to perhaps only show the button on rows 5 6 7  ? (just wondering if it is relative to the current record or such)

           

          Can you select the field on it's own and choose Bring to Front from the Arrange menu... (checking for stacking order)

           

          How were the buttons created? (I am assuming you used the button tool and the Theme but you didn't specifically say so best to check.)

           

          I use buttons in fields from the portal's table for this kind of thing and generally allow adding records in the portal row so the button is not present if the record is not present, leaving a clean new record row...

           

          I have not installed the update to 12.0.7... but will... and will let you know what I get.

           

          - Lyndsay

          • 2. Re: Portal row button missing
            heuristron

            Lindsay:

             

            Thanks for your response. I am able to scroll (swipe) down to rows 4 and beyond. I don't see the button in any of those rows. Tapping in the spot where I should see a button only selects that row, so the button is completely missing. I even tried adding button fill with visible outline—the button clearly disappears when scrolling to view hidden rows.

             

            The row button consists of a (script assigned) transparent button overlaying a trash icon (vector graphic). I checked the stacking order of the button and fields on the row and brought the button full forward in stacking order. This did not change anything—button is still missing on rows ≥ 4. I tried navigating the layout to different record and coming back—still no change.

             

            I used the button tool to create the button, probably had to clear out the theme defaults to set it to transparent. The button height is only about half the row height, centered vertically. I don't use relationship setting "Allow creation of related records…" for the portal displayed on layout. I like to avoid mixing UI methods within the solution to avoid interface confusion with end users.

             

            I am using an "Add new portal row" button script that uses a trick (global transfer method) from discussion at Pause On Error (Portland 2010-11). This is an adaptation that is portable enough to use in multiple locations. It saves having to Freeze Window, then go to the related table (Dev layout) to create the new record, populate fk_ field value with parent record ID, then pop back to original layout. I believe Todd Geist mentioned this method during one of his recent blog exchanges. To clarify, the relationship used for the portal on my layout is not the same one used for creation of related records, although they both use the layout table record ID (UUID) if that matters. I'll check to see if the empty global makes any difference, but don't see how since I've used it numerous times throughout the solution without losing portal row objects.

             

            I've used buttons in portal rows for years, and I've never seen missing buttons when properly placed in rows [I acknowledge FM Go is mobile version of FileMaker with its own quirks]. I tried deleting a visible row (top 3) using scripted delete portal row and saw the list change—next hidden row moved up with button now appearing and functioning. I can see/edit the field values in all rows just fine. It's weird, I know.

             

            The mobile solution I'm creating is the current centerpiece for my client's mobile users. I hope to convince this client to consider a hosted solution so daily transactions are available for use at the office, and status of field tasks are mutually available to other mobile users who share a peer itinerary. But first, they need a stable mobile solution.

             

            –Heuristron

            • 3. Re: Portal row button missing
              heuristron

              Lyndsay:

               

              Okay, I found a solution that works. I replaced the faulty portal and all objects contained therein on my layout. Amazingly all portal rows now display the row button, and the delete function is again available for every row. I think there may have been some object corruption that somehow developed on the layout. Reconstruction of layout portions was the most expediate resolution. As puzzling as this has seemed, I feel this issue is resolved for me. I'm back on development schedule again.

               

              Thank you for your time and patience looking at this mistery with me. I appreciate your thoughtful exploration and feedback.

               

              –Heuristron