4 Replies Latest reply on Aug 20, 2013 8:52 AM by BillisSaved

    Allow User To Override During Data Entry is not working...

    BillisSaved

      Hey Everyone,

       

      Thanks in advance for any assistance you are willing to provide to help me resolve my issue. My sutuation is this, I'm using FileMaker 12 Pro Advanced to develop a database which will be used to track student training histories. I have a field for the student's date of birth which is configure to perform validation on data entry to ensure the field is not empty. I've also provide the user permission to override this validation process during data entry. The problem is that, although these settings work perfectly when the database is opened on a Mac running OS 10.8.4, when I try to leave this field empty on a machine running Windows 7 I get no option to override the validation. Is this a known bug, or am I missing something? Thanks for taking the time to read this. Have a great day!

       

      God bless,

      Bill

        • 1. Re: Allow User To Override During Data Entry is not working...
          taylorsharpe

          I see no one else has responded.  I assure that is not the expected behavior and FileMaker on Windows does not respond differently to validation overrides.  Either there is a bug in the file or a bug in the Windows version of FileMaker (much less likely).  Have you tried this on multiple Windows 7 machines?  Also, in another FM file, can you duplicate this same behavior or does it behave properly in other files?  You might want to try to recover the file and see if it behaves the same.  And/or maybe rebuild the index of the field. 

          • 2. Re: Allow User To Override During Data Entry is not working...
            BillisSaved

            Hey taylorsharpe,

             

            Thanks for your willingness to help me! Please forgive my ignorance, I'm a novice FileMaker developer. Would you mind providing a bit more detail regarding the following two suggetions you offered:

             

            1. Recover the file?
            2. Rebuild the index of the file?

             

            Thanks again for your help. Have a great day!

             

            God bless,

            Bill

            • 3. Re: Allow User To Override During Data Entry is not working...
              taylorsharpe

              Close the file (or download it from the server if hosted on a server).  Open FileMaker Pro and go to File and pull down to Recover and follow the instructions.  FileMaker's instructions can be found at http://www.filemaker.com/help/html/recover.39.10.html

               

              Regarding the Index, just go File < Manage < Database and go to the table and field you are wanting to work with.  Click on the field options, then on the Storage tab.  Then click the option for "Indexing:  None" and then click OK.  Your index is now removed.  Close the Manage Database.  Then open it up again and go to the same place and turn the Indexing from None to All and click OK and you will have rebuilt your index. 

               

              See if that helps or not and let us know. 

               

              By the way, Server hosted files are corrupted far fewer times than files opened locally by FileMaker Pro.  If you need a very stable database, you'll want to consider purchasing FileMaker Server for this and a number of other reasons. 

               

              Cheers!

              • 4. Re: Allow User To Override During Data Entry is not working...
                BillisSaved

                Hey taylorsharpe,

                 

                It turns out the problem was a permissions issue. Apparently, the "Data Entry Only" default permission setting has the "Allow user to override data validation warnings" disabled. Once I modified that setting, the option to override validation became available. Thanks for your help! Have a great day.

                 

                God bless,

                Bill