3 Replies Latest reply on Sep 3, 2013 4:58 PM by Malcolm

    How Do You Prevent Data Validation When Adding Records In Scripts?

    jmci

      The Field Options dialog contains a radio button set that you can use to choose whether to validate data in this field "Always" or "Only during data entry". What is the difference between these two choices?

        • 1. Re: How Do You Prevent Data Validation When Adding Records In Scripts?
          ch0c0halic

          Perhaps you didn't see my response to your original post? This explains what the difference is (when importing). I suggest reading the help system, which really does have a lot of information in it. Please let us know if you don't Find what you need. Sometimes a specific example, like the import, can be clarified better.

           

           

          Reading the help comments I think this is how it works.

           

          8. For Validate data in this field, select Always for ongoing field validation, or Only during data entry to limit validation to instances when data is being entered. . .

           

           

          When doing an import adding records you are entering new records. So both options will perform data validation during the import.

           

          When import with matching fields and not adding new records then you are editing records and not adding new ones. Validation is not performed unless "Always" is selected or possibly if the data in the validated field is changing.

           

          When importing with matching fields and adding new records then when add new records the validation always occurs.

          • 2. Re: How Do You Prevent Data Validation When Adding Records In Scripts?
            Mike_Mitchell

            Perhaps if you explained a bit more precisely what you're doing, we could give you a better answer?

            • 3. Re: How Do You Prevent Data Validation When Adding Records In Scripts?
              Malcolm

              When import with matching fields and not adding new records then you are editing records and not adding new ones. Validation is not performed unless "Always" is selected or possibly if the data in the validated field is changing.

               

              Are you selecting "Auto enter" on the dialog box after you map the fields in the import dialog box?

               

              Forget about the settings for your fields. Pay attention to the auto-enter selection on the final dialog box you see prior to import.

               

              Do the import in two runs.

              In the first run, allow the system to auto-enter all values, serials etc. This sets up your records as if they had been entered manually.

              In the second run, turn off auto-enter values and selectively replace fields with the values that you want preserved.

               

              This method is necessary when you need to re-assert the values in fields that auto-enter creation date, modification date, created by, modified by, etc

               

               

              Malcolm