2 Replies Latest reply on Oct 24, 2013 7:22 PM by IanWilson

    Issues with Mavericks and PHP

    IanWilson

      I run FMPA 12.0v5 on my 15in rMBP together with FMSA 12.0v4. I also have Dreamweaver CC installed and FMstudio Pro. Up to the point when I installed Mavericks everything worked just fine. I was using the Apple installed version of PHP rather than FileMaker's and I had no issues whatsoever.

       

      Unfortunately, OS X 10.9 Server has brought my set-up to its knees. Here's what's happened so far:

       

      1. My Java runtimes got hosed, so I had to reinstall. The Server 3 version is a little different from Server 2, but I'm sure there are much bigger changes under the hood, including ...

       

      2. PHP is now at version 5.4.17 and this is radically different from the previous version installed with Mountain Lion. It took me ages to sort out what the problems were but I eventually got PHP up and running again.

       

      3. FMSA is working just fine ... there are no issues to speak off running under Mavericks Server, but ... all my webpages which use the FileMaker PHP API no longer work. Regular PHP connections to MySQL are OK, but I can no longer create a connection in Dreamweaver to FileMaker server. When I try, I get the error "Connected to server, but the login failed (0.0)". Followed by "An error occurred while attempting to establish a connection to the FileMaker Server." Running the FileMaker PHP pages in a browser (Chrome, Safari and Firefox) results in an Error 22 code (Unknown error).

       

      In an effort to track down the issue I zapped all my extended permissions on my FMSA hosted database and deleted the user account which is used by my FileMaker PHP pages. I then recreated the user accounts and the extended permissions, but the issue still persists.

       

      Yesterday, I bought a new Mac Mini to use solely as a FileMaker server. I'm currently downloading Mavericks and when it's complete, I'll reinstall FileMaker Server Advanced on it, using the Apple installed version of PHP. If it still doesn't work, I plan to wipe the Mac Mini hard drive, reinstall Mavericks and then FMSA, but this time I'll use FileMaker's PHP.

       

      I've been relying on FMstudio Pro to create all my FileMaker PHP code and the one thing I haven't tried is hand-coding a few pages to see if the problem persists.

       

      Has anyone else experienced any issues with a similar set-up?

       

      Ian