5 Replies Latest reply on Jul 13, 2017 3:20 PM by davidsan

    Filemaker Spelling

    davidsan

      I have a Filemaker solution that is accessed using a Filemaker Pro 11 Client in a Windows machine. Windows XP on this particular machine is in English. However, the report the person has to fill is in Spanish.

       

      If I change the spelling language for the report to Spanish, it works correctly, but as soon as I close FileMaker Pro and reopen it, the spelling dictionary is in English by default. It does not make any difference if the interface of the FileMaker is set to Spanish or English. It seems like the spelling dictionary resets to the Windows language.

       

      Does anybody know a way to configure the spelling dictionary to be in Spanish always? Could It be something weird with this particular Windows installation? (I had to ask permissions to the IT department in order to install FileMaker on this machine).

        • 1. Re: Filemaker Spelling
          PeterWindle

          There is a "Select Dictionary" script step, but this will prompt the user to select the dictionary, it would be nice if it could perform this step without the dialogue box, but alas, it does not (feature request??). Not sure how filemaker chooses the default dictionary...?

          • 2. Re: Filemaker Spelling
            Stephen Huston

            It is possible to remove any unwanted spelling dictionaries from the FileMaker installation on a specific machine, leaving only the dictionaries you want. If that client machine is intended to be used only in Spanish, try removing other dictionaries from the FMP application directories.

             

            [I recommend you move them to another directory outside the FM application folder so you will be able to put them back later. You could trash them, but then you would need to do a new install to restore them if you ever wanted them back.] Good luck with IT.

            • 3. Re: Filemaker Spelling
              davidsan

              I would give it a try at this solution.

               

              I still think IT might be blocking some directory or the ability to write the Filemaker preference. I tested the solution on a Mac with the Mac in English and FM in English. If I set the spelling to Spanish even after rebooting the preference stays.

               

              Does anybody know where Filemaker preference file for Spelling is located in Windows?

              • 4. Re: Filemaker Spelling
                Stephen Huston

                I think if you go to the built-in Help menu and enter "Dictionary" in the search box, it will direct you to that info for your version/system.

                • 5. Re: Filemaker Spelling
                  davidsan

                  After trying all suggestions given I finally discovered how to solve this issue. It may applied to other systems, including Windows 7 or more recent releases so I share the solution.

                   

                  Since Windows is locked by the IT department, it is not possible to change the default FileMaker preferences. FileMaker changes the Spelling dictionary to English because the Windows OS is in English. I had to ask to the IT department for a temporary admin account (15 minutes) and change the registry entry. I did this by typing regedit in the command prompt and navigating to this location:

                   

                  + HKEY_CURRENT_USER

                     + Software

                         + FileMaker

                             + FileMaker Pro

                                 + 11.0

                                     + Preferences  

                                         MainDictionary ---> C:\Program Files\FileMaker\FileMaker Pro 11 Advanced\Extensions\Dictionaries\english.mpr

                   

                  And change it to:

                                         MainDictionary ---> C:\Program Files\FileMaker\FileMaker Pro 11 Advanced\Extensions\Dictionaries\espanol.mpr

                   

                  Once I restarted the computer with a non admin account, the dictionary was set to espanol and since FileMaker cannot change the preference because it requires an admin account it works perfectly.

                  1 of 1 people found this helpful