argwallace

Runtime bug in 12.0.5 Mac

Discussion created by argwallace on Nov 15, 2013
Latest reply on Jan 7, 2014 by aÿd

Hello,

 

I have been developing a solution for Mac users using the Runtime application. Since version 11, I have been using an Applescript command which creates events in the Calendar (iCal) application. This has workd without issue, even into version 12. Howeverm since upgrading to Mavericks and updating the Runtime engine to 12.0.5. I have found that the applescript command is producing a delay of almost a minute to run. When I run the same command from my FMA12 for Mac, it works just fine. I've recreated the runtime and can verify that it continues to happen. Also, when I run the syntax from the AppleScript Editor, it works just fine as well, returning no errors. The only error comes from within the Runtime.

 

Any thoughts or suggestions? I notice that in the Activity Monitor a process called "tcdd" spikes. This seems to be related to the contacts permissions database. I gave rebuilt this, stil to no avail. It seems it would need to be related to the calendar, not the contacts. Quite frustrating.

 

Thanks in advance for any suggestions. We have approxiamtely 650 users for the runtime all on my Mac for our organization.

 

Regards,


Stephen

Outcomes