3 Replies Latest reply on Dec 3, 2013 12:56 PM by Stephen Huston

    FMP12 Printing PDFs Generates PostScript Font Error

    MissJack

      We recently decided to change the font of our printed materials from Arial to Cambria, but when we create PDFs within FMP12 and then try to print them, either directly from an FMP layout or after saving the file locally, our two PS-enabled network printers will only print the first few lines and then generate a PostScript error...

       

      ERROR: invalidfont

      OFFENDING COMMAND: cshow

       

      STACK:

       

      (2/19/13)

      (--pop-- --pop-- ct_strl --exch-- 0 --exch-- --put-- ct_strl --show-- {

      _ct_na _ct_i --get-- }--stopped-- {--pop-- --pop-- } {_ct_x _ct_y --

      moveto-- 0 --rmoveto-- }--ifelse-- /_ct_i 1 --add-- --def-- --

      currentpoint-- /_ct_y --exch-- --def-- /_ct_x --exch-- --def-- }

       

      Configuration Details

      FileMaker Pro 12.0v4

      Windows 7

      Adobe Reader X and/or a third-party program (e.g., PDF Creator, PrimoPDF, etc.) - NOT Acrobat

      Dell 3330dn Laser Printer PS3 and XL

      Microsoft ClearType Collection Cambria TrueType CID-keyed font (which I believe makes it a PS Type 1 font)

       

      PDF Creation, Storage & Display

      The files are created within a script using the Save Records as PDF script step, saved to a network drive, and a reference to the file is stored in a container field using the Insert PDF script step. The file is then displayed on a simple layout with the container field optimized for interactive content. The file displays perfectly in all its Cambria-esque glory. From here, the user has the option to use the Adobe menu icons within the container field to either print the file or save it locally (in order to print it later, or attach it to an email to send to clients). We've also provided a button on the layout that saves the file locally using the Export Field Contents script step. And here is where we run into problems...

       

      Printing

      Printing from the layout, or opening the locally saved file in one of the PDF handlers listed above and trying to print from there, results in the aforementioned PS error, UNLESS, you select Print as Image in the print dialogue, OR Print to File using one of the handlers (but the quality is way crappy after something like that).

       

      As I have Adobe Acrobat X installed, and use a locally connected plane old discontinued Brother laser printer, I am not able to reproduce the problem on my own machine, only on the user machines. However, if I create the file on my machine, then grab it from a network drive and try to print it from one of the user machines, I get the same error. BUT, if I'm on a user's machine and send the print job to a low-tech local printer, voila! Perfectly rendered Cambria font.

       

      I have checked...

      FMP script step settings

      Default PDF handler settings

      Printer driver settings (for the Dells and the PDF handlers)

      Printer hardware settings

      Document file properties (Cambria font is properly embedded, at least, that's what it says...)

      Font specifications and PostScript compatibility issues

      Multiple means of saving and printing

      Multiple configurations of computers, software and printers

      Issue reports on FM, Adobe, Microsoft & Dell forums

       

      From all of that, it seems to me that there is some sort of PS or embedding flaw on the FM end that Acrobat is somehow magically able to fix/overlook, but Reader/third-party handlers/PS printers are not.

       

      I don't have administrative privileges for dealing with the network printers, so I haven't had a chance to double-check that all our drivers are up to date, so that might have something to do with it, but I doubt it, as we're pretty good at staying on top of updates.

       

      Is anybody else having this kind of problem, or have any idea how to solve it without giving everyone their own local printer? We simply can't afford to install Acrobat on every user machine just to solve a printing error, either. Are we just doomed to settle for Arial as our default printed font? (Oh please, no...) Any suggestions on where else I should look to get a bead on the disconnect here?

       

      I've reported this as an issue on the FM Forum, so you can have a look here for more details or any discussion that arises.

       

      Thanks for your help!

        • 1. Re: FMP12 Printing PDFs Generates PostScript Font Error
          Stephen Huston

          From your description of the combinations that work and those which fail, it sounds like there is a  problem with the target printer.

          • It may need its drivers updated.
          • There may be an older version of the font embedded in the printer's PostScript software version.
          • There may be an inconsistency between fonts on the computers and in the printer.

          All of these  tend to point to printer driver updates. If there are no newer drivers for that printer, sometimes selecting a generic printer driver can resolve it, but that often relies on the client machines' settings or printer plugins.

           

          There are also Print-to-PDF drivers other than Acrobat which can downloaded and used by client machines, including freeware:

          PDFCreator, Bullzip PDF Printer, etc.

          1 of 1 people found this helpful
          • 2. Re: FMP12 Printing PDFs Generates PostScript Font Error
            MissJack

            Thanks for your suggestions, Stephen.

             

            Our facilities team is in the process of confirming that the drivers for both network printers are up to date right now, so hopefully (fingers crossed) there's an update available that will fix this problem.

             

            Concerning the fonts, when you say

            the font embedded in the printer's PostScript software version

            are you referring to the "system" fonts that the driver relies upon when it can't (for whatever reason) read the fonts embedded in the PDF (or is told not to)? If so, would that be the same thing as the PostScript Emulation Fonts that are listed in the printer menu?

             

            The reason I ask is that I printed out the lists of the PostScript Emulation Fonts for each of the printers, and Cambria does not appear among either of them. However, I thought the point of designing TT (CID, Type 1) fonts was so that they could be read by the PS programming without needing that specific font to be embedded in the printer's software. Or maybe I'm totally misunderstanding all that? Maybe if the font isn't on the printer (the extremely complex and pricey printer that's supposed to be so much better at rending fonts than the crappy old one that prints them with no problem), then we just don't get to print anything in that font? But that can't really be the case, can it? (Also, isn't it just supposed to replace the offending font with one of the system ones, rather than giving me that weird error?)

             

            My second question about fonts is how to determine inconsistency or corruption in font files. I've seen other posts that suggest maybe there's some sort of mismatch between the Windows font file and the one embedded in the PDF, but I'm not sure how to go about determining whether that's actually the case, or how to fix it if it is. Would I need to, say, uninstall the font file and then reinstall it on all the user machines? In the case of the printers, I'm assuming that any driver updates would take care of font file inconsistencies, but maybe there's an external process for this as well that I should look into?

             

            And I'm not as familiar with Acrobat as I probably should be, so maybe there's a way for me to examine the embedded fonts in the PDF file more closely? So far, I've only been able to see a list of embedded fonts in the Document Properties window, but I just have to take it at face value that they are in fact properly embedded.

             

            As far as print-to-PDF drivers, we have a number of different ones (including PDFCreator) installed on various machines throughout the office. I have tried using all of them, with all sorts of combinations of settings adjustments, and while I can eventually get the file printed in the correct font, none of them are able to solve the problem directly. In other words, from the layout in FileMaker, the user has to make an extra step (or several, depending on the driver) to send the file through the third-party driver.

             

            For instance, if they just want to print the file (rather than save it), they can't use the print icon within the container field (because that's the native Adobe button), but instead have to use the File menu to print, then select Print to File from the proper driver, then go open the file and print it from within the third-party program. When they're doing this dozens of times a day, that's a huge waste of time. Also, the quality of our header and footer graphics are noticeably diminished during this process.

             

            In any case, your suggestion about the drivers seems to be my best avenue for troubleshooting at the moment. But if you can answer any of my questions here, or provide any further insights, that would be most appreciated.

             

            Thanks for your help!

            • 3. Re: FMP12 Printing PDFs Generates PostScript Font Error
              Stephen Huston

              My comment about fonts embedded in the printer software has to do with the fact that many printers come with PS fonts embedded, which supposedly allows documents to transfer and raterize faster in the printer because the font code is already there as part of PostScript software already in the printer. If the printer has a font with the same name or the same ID as is used by the client computer document, it just uses the code in the printer already instead of reading that from the file.

               

              I have heard of instances where fonts used the same ID for different versions, and the result was not pretty in the printout.

               

              Some printers also do font substitution where they lack an internal font, and those results can vary a lot.

               

              There have even been versions of Acrobat which allowed the user to control the choice between embedded fonts in the document, and system or printer fonts for screen rasterizing and print.

               

              Usually, using the latest printer drivers resolves the most common of these errors, but using a font which is outside the scope of the printer embedded fonts does mean that the full postscript of the PDF has to be eownloaded to to the printer RAM. In those cases, setting the printer's advanced options to print the PDF as a graphic usually clears up the problem, because that causes the PS code to be read in full by the printer.