1 Reply Latest reply on Nov 27, 2013 7:06 PM by rgordon

    File access error in fmGo

      I have developed a few solutions that follow the filemaker syncing guide for offlining data for a mobile device. Today I started encountering an error I can't resolve. The mobile file has a sync file stored in a global field. The sync file has TOs to the mobile file and the hosted file. The sync script starts by exporting the sync file and then running a sync script on the sync file. Today I started getting this error when opening the sync file on either my iPhone (running iOS 6.1.3) or on my iPad (running iOS 6.1.2) :

       

      "<filename>.fmp12 is currently in use nad could not be opened. If the file is shared, you can open the file on the network. (if you've opened the file before, check the recent Files list.)"

       

      Of course the file it's trying to open is open but since the external data source is in the same directory as the sync file it should not be giving this error. The mobile file works fine on my laptop. I've tried making the external data source use the .fmp12 extension and without it and get the same result.

       

      Is this a compatibility issue with fmGo 12.0.8 and iOS 6?

       

       

      update: I just upgraded my iPhone to iOS 7 but it didn't resolve the problem. What am I missing?

       

      Peace,

      Christi