3 Replies Latest reply on Dec 3, 2013 2:51 PM by raycon

    FM12ADV Scripts Works but with a Message that Script not found or deleted

    mansurmahmud

      I posted this disaster yesterday. I have developed an application known as eWorks. This application as hundreds of Scripts. ALL of them were working fine until yesterday. Suddenly it started giving error messae [SCRIPT NOT FOUND OR DELETED] and the strange thing is it executes the Script. It applies to very simple scripts such as [GO TO LAYOUT]

       

      I tried the following

       

      1. Remove and deleted the script and re-created the script. - It did not work

      2. Tried to recover and it gave a message as attached.

      3. When nothing worked. I took the backup file and it started working fine until I added a new Script. The moment I added new Script. ALL other Script again started giving the same error [SCRIPT NOT FOUND OR DELETED] AND it executes the script

       

      I don't know what to do

        • 1. Re: FM12ADV Scripts Works but with a Message that Script not found or deleted
          raycon

          Can you post the entire recovery log so I can see what is happening there?

           

          Also have you made any other changes to the file references?  e.g are you referencing external files or is this all one big file?

          • 2. Re: FM12ADV Scripts Works but with a Message that Script not found or deleted
            mansurmahmud

            Dear Raycon

             

            No references to external sources. Please find error log. It is all

            corrupted. Why? or what to do? I have a strange feeling it is hacked for

            some unknown reason.

             

            Thanks for your prompt response

            • 3. Re: FM12ADV Scripts Works but with a Message that Script not found or deleted
              raycon

              I don't think it's hacked. Is it possible the drive it is on is damaged and needs repair/replace?

               

              This last section of the log suggests that you should rebuild your database from a back-up copy that you know is not corrupted, and that would be my suggestion also.  It may also be advisable to run a diagnostic on the drive before doing anything else, assuming you have a backup that is not on the at drive.

               

              2013-12-03 14:44:46.275 +0400eWorksDev12 Corrupted.fmp120Deleted last used page format
              2013-12-03 14:44:46.276 +0400eWorksDev12 Corrupted.fmp120Deleted last used print settings
              2013-12-03 14:44:46.277 +0400eWorksDev12 Corrupted.fmp120Deleted last used layout formatting defaults
              2013-12-03 14:44:46.278 +0400eWorksDev12 Corrupted.fmp120Deleted last used import orders
              2013-12-03 14:44:46.279 +0400eWorksDev12 Corrupted.fmp120Deleted last used export orders
              2013-12-03 14:44:46.279 +0400eWorksDev12 Corrupted.fmp120Deleted last used sort orders
              2013-12-03 14:44:46.280 +0400eWorksDev12 Corrupted.fmp120Deleted last used request sets
              2013-12-03 14:44:46.281 +0400eWorksDev12 Corrupted.fmp120Deleted last used found sets
              2013-12-03 14:44:47.913 +0400eWorksDev12 Corrupted.fmp128495WARNING: problems were detected while recovering the database.  The recovered file should NOT be used going forward; copy only the most recent work from it into a backup copy of the original file.
              2013-12-03 14:44:47.914 +0400eWorksDev12 Corrupted.fmp120File blocks: scanned and rebuilt 15481 block(s), dropped 0 invalid data block(s)
              2013-12-03 14:44:47.915 +0400eWorksDev12 Corrupted.fmp120Schema: scanned fields and tables; some problems were found...
              2013-12-03 14:44:47.916 +0400eWorksDev12 Corrupted.fmp120  fields created to match record data: 0
              2013-12-03 14:44:47.916 +0400eWorksDev12 Corrupted.fmp120  field values deleted due to invalid ID or repetition: 0
              2013-12-03 14:44:47.917 +0400eWorksDev12 Corrupted.fmp120  records deleted due to invalid ID: 0
              2013-12-03 14:44:47.918 +0400eWorksDev12 Corrupted.fmp120Structure: scanned; 1 item(s) modified
              2013-12-03 14:44:47.918 +0400eWorksDev12 Corrupted.fmp120File size after recovery is 62820352 bytes
              2013-12-03 14:44:47.919 +0400eWorksDev12 Corrupted.fmp120*** Completed recovery to 'eWorksDev12 Corrupted Recovered.fmp12'