2 Replies Latest reply on Dec 30, 2013 1:09 PM by PeterWindle

    Runtime Creation Error FMAdv v11 (MAC)

    PeterWindle

      Hello all,

      I am getting an error when creating runtimes, regardless of the files I am trying to 'bind' on the Mac...

       

      Whenever I run the binding process, I get the error :

      "This file is locked or in use" and it seems to happen when the process gets to the "Internal Runtime Libraries" > "Info.plist" file.

      (see enclosed pict)

       

      Is there anyway of fixing this apart from re-installing the OS or FileMaker Pro 11? I have tried permissions repair.

      FM Pro Advanced 11v4, Mac OS 10.9.1

        • 1. Re: Runtime Creation Error FMAdv v11 (MAC)
          PeterDoern

          Hi Peter,

           

           

          I had the same problem with FMPA 13 on OS X 10.9.1. Here's how I fixed it:

           

          1. Navigate to the folder containing Filemaker.

          2. Drill down to FMI Runtime Resources/Internal Runtime Libraries

          3. Control- or right-click on Runtime and select Show Package Contents

          4. Open the Contents folder

          5. Select info.plist and Get Info

          6. Change Sharing and Permissions (at the very bottom of the Get Info window) so that everyone can read and write.

           

          Changes should take effect immediately.

           

           

          Peter

          • 2. Re: Runtime Creation Error FMAdv v11 (MAC)
            PeterWindle

            Thanks Peter, actually, I worked this one out for myself, but what threw me is that because I am running three versions of FileMaker pro on my mac, I had to find out which resource was causing the problem, for some bizzarre reason, it was a different version of filemaker pro that was causing the problem than the one that was creating the runtime...!

            I applied the same thing to all three versions on my mac just to be sure and fair enough, problem solved. Thanks for the reply!