5 Replies Latest reply on Jan 5, 2014 6:02 AM by IanWilson

    Hiding the Zoom Control Area

    IanWilson

      Happy New Year everyone!

       

      I'm developing on a Mac running Mavericks and FMP 13 Advanced. Is there an elegant way to hide the Zoom Control Area on the first window (and subsequent ones too) after opening a database?

       

      Cheers

       

      Ian

        • 1. Re: Hiding the Zoom Control Area
          mikebeargie

          Use the "new window" script step.

           

          Specify "advanced options"

           

          uncheck "zoom control area" checkbox.

          • 2. Re: Hiding the Zoom Control Area
            IanWilson

            Hi Mike:

             

            I'm aware of the steps you outlined, but it's not exactly what I'm looking for. I need the very first window to appear without the Zoom Control Area. Since what you have outlined has to be scripted, it must be triggered from a visible layout that has the Zoom Control Area visible.

             

            No matter what I try, I get a 'flashing' brief view of the first window ... not very elegant, I'm afraid!

             

            Cheers

             

            Ian

            • 3. Re: Hiding the Zoom Control Area
              mikebeargie

              I guess you're more elegant than I am!

               

              If you wanted to make it more "elegant" way to do what I suggested, than you could lock the zoom first, load the first layout in the second window with the exact same dimensions, and sans zoom controls, then close the background window. This would (at least) not have the first window be a blank flash of window.

               

              Or you could create a loading screen and a .5 second pause in your script for the first window (and give yourself some credit in the process).

               

              No idea if, but theoretically it might be possible with a plug-in installed to override the default first window style.

              • 4. Re: Hiding the Zoom Control Area
                hbrendel

                My 'OnFirstWindowOpen' script starts with these two script steps:

                 

                New Window [Name: "Welcome"; Style: Document]

                Close Window [Name: Get ( FileName ); Current file]

                 

                Of course the first step has the right options set.

                 

                I'm not seeing any flashing, no matter how hard I try to. Maybe it's my SSD-configuration...

                • 5. Re: Hiding the Zoom Control Area
                  IanWilson

                  Thanks for all the replies. Creating a new window and then hiding the original was what I've been doing. I think the flashing is being caused by me hiding the Toolbars as well. There's just a momentary flash of the original toolbars before they disappear.