vavo

Insert From URL and JSON mysterium

Discussion created by vavo on Jan 13, 2014
Latest reply on May 11, 2014 by DonCollier

Hi,

 

I have built a nice database that uses isbndb.com to get data about books. To do that I use their JSON api which worked great until a few days ago...

 

Here are the steps:

$url_to_insert contains a URL like this: http://isbndb.com/api/v2/json/[your-api-key]/book/9780849303159


Insert From URL (select;No Dialog; ADMIN::JSON_DATA; $url_to_insert)

 

This used to just simply insert the returned data in my global field JSON_DATA and I could parse it from there.

 

Now the field stays empty and I get error 507 in the debugger.

Other websites work just fine.

The same URL pasted in a browser works.

THe same URL used in a webviewer in FMP works.

 

I am really at a loss. I even tried changing the field JSON_DATA to a container field and guess what: Insert from URL puts a nice little text file with the JSON code I want in there. I just simply cant get the text.

If it helps: I am on OSX Mavericks, FMP Adv. 12.0v5.

 

Does anybody have an idea where to look?

 

Thanks,

 

Valentin

Outcomes