4 Replies Latest reply on Feb 7, 2014 6:22 AM by 2mike.co.uk

    webdirect - video not working in browser

    2mike.co.uk

      new database in fm13 for use in webdirect. i have tried formats mp4 and .mov in interactive containers and the videos display correctly in filemaker pro but when uploaded to external server only an icon and the filename show. they are both less than 10mb.

      regards

      michael stewart

      www.2mike.co.uk

        • 1. Re: webdirect - video not working in browser
          mikebeargie

          Not sure if this addresses your issue:

          http://help.filemaker.com/app/answers/detail/a_id/12049

           

          Can you export the field contents via webdirect and play the video?

           

          It sounds like maybe your browser doesn't have the ability to play the video, so it shows the icon from the container metadata instead.

           

          What OS and browser are you using?

          • 2. Re: webdirect - video not working in browser
            2mike.co.uk

            Thanks Mike. At the moment, I just see the mp4 icon/file name and no link to unblock security etc. The videos play when exported and play in FM Pro 13. I have tried on various systems including safari, windows 8 and Internet Explorer 11 and always just the icon. Also tried reinstalling quicktime etc. Any other ideas very welcome.

            • 3. Re: webdirect - video not working in browser
              ChrisStapleton

              I've had mixed results with mp4's recently. I had a new FM13 database that was playing them perfectly in both FileMaker Pro and via WebDriect. I was very impressed with the near identical functionality. And, the same experience across Explorer 9, Chrome 32 and Firefox 26. That was a couple of weeks ago.

               

              Then I applied an SSL certiifcate to the server as well as other OS updates (Windows Server 2008 R2). Now the same database and content behaves differently. FileMaker playing of mp4's as before. Chrome also as before. Firefox displayed a link that when clicked opened up another tab and played the mp4 from there. Explorer displayed a small icon and appeared to do nothing.

               

              Turned Web Publishing off and then back on via the Admin Console. Now Firefox plays the mp4's as before. Explorer still shows the small icon and appears to do nothing - but actually it's just waiting and suddenly out of the blue springs into life (1 minute for one video (43Mb), 4 minutes for another (96Mb)). So it looks like Explorer is not allowing the streaming of the content and something similar. Will be trying a complete server restart when I get a chance to see how that effects things.

              • 4. Re: webdirect - video not working in browser
                2mike.co.uk

                chris, many thanks for the info.  i have given up trying to fix this and have started to use fm webviewer linked to streaming video provider  www.streamingvideoprovider.co.uk    webdirect is ok for pics but video is just rubbish.

                regards

                mike