LabsRock

MySQL ODBC errors in FMS 13

Discussion created by LabsRock on Jan 24, 2014
Latest reply on Jan 24, 2014 by LabsRock

We recently upgraded to FileMaker Server 13 and I'm now getting an ODBC error when creating new records in a connected MySQL database - "Server does not support 4-byte encoded UTF8 characters" (see attached).

 

We're running on a Windows 2008 Hyper V VM which had previously been running FMS 11 without a problem.

 

I've tried updating the driver (now using MySQL ODBC 5.2 both ANSI and Unicode - listed in that order) and changing the Text and VarChar fields in the MySQL database to a different character set to no avail. I receive an error when installing the new MySQL Drivers (also attached) suggesting the insallation can't be completed, but if I click Ignore, the installation seems to complete and the drivers appear in the ODBC Data Source Administrator as expected. I can't rule out that there is a problem with the installation, but since I was getting the same error prior to the update I figure I'm none the worse for it.

 

Perhaps there is an appropriate character set to choose for the MySQL fields, but I'm not sure what it is.

MySQLODBC_Error.jpgMySQLODBC_InstallError.jpg

Any input would be greatly appreciated.

 

Craig

Outcomes