AnsweredAssumed Answered

Account creation will not complete

Question asked by mbust on Mar 1, 2014
Latest reply on Mar 15, 2014 by mbust

Hello everyone,

 

In a FM 11 database hosted in a server I have about 1200 accounts. There I have a script that creates accounts when someone's registration confirmation is received from PayPal. With a similar script that creates the accounts I migrated all the 1200 users from the old system into the FM database (a happy day!). But ealier today, using the same script command to add an account, the database hanged for a long time when I tried to add a user (that is, the step never completed and I got the beach ball cursor). Since I could not create the account with the script (I waited for about 3 hours for the script step to complete), I then tried it by just going to the Manage Security menu and adding the account directly. I entered the account details and clicked OK to save the account back to the server, and after about 30 minutes, the Adminstrative validation window came up. I entered my administrative username and password and waited about 2 more hours for it to save but it never completed (the beach ball kept displaying). Eventually I just got on the console and disconnected myself from the server, to try again. But it did not work; the account had not been created. Every attempt would end up hanging as in the past.

 

The only difference that I can think of between now and when it used to work was that before I had less then 10 registered accounts, and now I have about 1200. Thinking that perhaps it was the connection between the server and my copy of FM 11 Pro that was the problem, I created a web page that triggered the script that creates the account. The page is a simple link that loads another page that triggers the script, sets a session variable, and returns me to the original page with a message from the session variable. But here, too, the db hangs. The link goes to the second page where the script is triggered, and it never returns back to the original page (presumably because the script never completes). The step that never completes is the Add Account script step, but like I said, the same thing happens from the Manage Security menu.

 

Can anyone help me troubleshoot this? Thanks.

Outcomes