10 Replies Latest reply on Dec 18, 2016 9:56 AM by JackRodges

    Avoid FMGo Connection Interrupted

    IT_User

      Hello

      I am made a visitor log system on an iPad.

      It needs to be always on, so I made the iPad not sleep. That also means the file cannot be disconnected from the server.

      Also, in the file I turned off the "Disconnect user from server when idle" and the "fmreauthenticate" in the security of the user.

      However, I believe since the server still disconnects user after a time period it gives the error "Communication with the host was interrupted. Do you want to try to reconnect?" I can't turn that off, since the server holds other files that would need for people to be automatically disconnected.

       

      I would have the file just on the iPad instead of remotely hosted, except that the information needs to be immediately available to the desk right nearby, so that they can do things in FM there.

       

      The only other option I might be able to try is Peer-to-Peer hosting, but I have never been successful in setting that up.

       

      Can anybody help with options?

      Thanks!

        • 1. Re: Avoid FMGo Connection Interrupted
          Mike_Mitchell

          There are at least two options I can think of right away:

           

          1) Make your iPad database local only (no continuous connection to Server) with a sync / upload component. That is, when needed, the user taps a button that initiates a server connection, performs the data update / transfer, and then disconnects.

           

          2) Use Custom Web Publishing to convert the "always on" application into a web page. By nature, web pages (without extra help) are stateless and do not require constant communication with the host.

           

          I'd avoid peer-to-peer hosting. It's inherently less stable, less secure, and more error-prone than Server, and more likely to damage your database.

           

          I've attached a copy of a white paper on sync strategies for your review.

           

          HTH

           

          Mike

          1 of 1 people found this helpful
          • 2. Re: Avoid FMGo Connection Interrupted
            DavidJondreau

            You turned off reauthenticate? That should be on. It won't keep you from getting disconnected but it will make logging in much easier, especially with a high setting (fmreauthenticate10080).

             

            I don't think this is a Server issue. The error message you're getting suggests network hiccups.

             

            FMP likes an "open line" to its host. If the wifi goes down for 20 seconds, or the server takes a nap, or you switch apps, then FM will disconnect.

            • 3. Re: Avoid FMGo Connection Interrupted
              Paul Jansen

              I haven't tried this, but perhaps a an OnTimer script would stop the server from disconnecting you. (as long as the interval is less than the server timeout!!)

               

              Cheers

               

              PJ

              1 of 1 people found this helpful
              • 4. Re: Avoid FMGo Connection Interrupted
                IT_User

                I guess I would have to go with Option 1, since I still want the ease of use for capturing pictures and signatures.

                 

                Thank you for the white paper and the suggestion.

                • 5. Re: Avoid FMGo Connection Interrupted
                  IT_User

                  Ok, I turned fmreauthenticate back on.

                   

                  It could be network hiccups.  Thanks for the idea

                  • 6. Re: Avoid FMGo Connection Interrupted
                    IT_User

                    I do have an OnTimerScript, which all it does is take the file to a comepletely black layout (to prevent image/screen burning), but I think it gets uninstalled as soon as it gets to the layout.  So I guess I could try one that runs continuously.

                    Thanks!

                    • 7. Re: Avoid FMGo Connection Interrupted
                      Mike_Mitchell

                      One thing that I've done in dealing with network hiccups is to create an opener file that runs as an OnTimer script. Every so often, it checks to see if the hosted file is open. If not, it opens it.

                       

                      However, one weakness of that approach is that it depends on the user acknowledging the "disconnected" dialog. Might not be a huge issue in this case, but since that dialog hijacks the client, it'll stop the OnTimer script from processing.

                       

                      Just a thought.

                       

                      Mike

                      • 8. Re: Avoid FMGo Connection Interrupted
                        rgordon

                        I don't think this is a server issue.  It is probably an iPad issue or WiFi issue.  Here are a couple of things to look at:

                         

                        1.  There is definitely a correlation beween how long it has been since the iPad was restarted and the number of problems you experience with FM Go.  Suspect that FM Go has some memory management issues.

                        2.  Is the iPad mobile?  If yes, you might be experiencing WiFi drops.  I'm assuming you are using WiFi. If you are using a cellular network then all bets are off.  I would not trust a cellular network to maintain a consistent connection

                        3.  FMGo should try to reconnect when it gets disconnected but there is a huge gotcha.  If you have an uncommitted record you will end up in a revert from hell loop.  Try to minimize any uncommitted records.

                         

                        I initially thought the iPad going to sleep was the cause of these problems, but i could not confirm this through testing.  If everythihg is working the way it should the iPad should just reconnect with no problem when it wakes.  I think what you are seeing are network connection problems that occur during the sleep or just prior to sleep but were not a result of the iPad being asleep.  So what happens is you might assume that the cause was the iPad sleeping since you can not reconnect when it wakes up.

                        • 9. Re: Avoid FMGo Connection Interrupted
                          IT_User

                          The iPad does not move, and it is in a holder where none of the buttons can be pushed.  (The worst that can happen is that it gets unplugged.)  I put the iPad in kiosk mode so they can't touch things to even get out of the app. (like the top left and right areas).

                           

                          It is connected by WiFi, not cellular, and it never goes to sleep.

                           

                          It's new, not much is happening with it, and it is not that big, but it could be a memory management issue.

                           

                          So it is probably a network hiccup issue, like other people have said.

                          It does try to reconnect, but gives that message before doing so.

                           

                          Thanks for responding!

                          • 10. Re: Avoid FMGo Connection Interrupted
                            JackRodges

                            The log file can be a local file which eliminates the problem with the server. If needed you can push the data to the server as needed. Making the login file local solves your problem.

                             

                            Login with this file and have buttons on it to open your server file.

                             

                            You could pass the login info in the parameter of the script that opens on the server and save that to your server login in table and then open the appropriate script.

                             

                            Perform script( On server; parameter $logindata; script to run after login recorded)