1 2 3 Previous Next 32 Replies Latest reply on Sep 26, 2014 10:12 AM by steveromig

    Layout mode - FileMaker 13 not responding

    dburnham

      Have others been experiencing a new behavior in FileMaker 13 where in Layout Mode, the application becomes non-responsive for no apparent reason, requiring either an enormous degree of patience until the spinning ball (mac) is done doing its thing and returns to a cursor, or a force-quit becomes necessary, of course losing all unsaved work?

       

      When it hangs up and eventually does come back to responsiveness again, I'm talking about a waiting period of about 3-5 minutes.

       

      To give an example, this is one that I was able to reproduce several times today: I select a field label and use the format painter tool to apply the format to a number of other field labels. Clicking the first new field label, no problem. Clicking a second field label, no problem. Clicking the third field label: spinning ball begins. 4 minutes later, I have my cursor (paintbrush) again.

        • 1. Re: Layout mode - FileMaker 13 not responding
          JavierDura

          Change the theme of that particular layout to "Classic" and then change it again to any other theme.

          1 of 1 people found this helpful
          • 2. Re: Layout mode - FileMaker 13 not responding
            Vyke

            I've been having this issue with files that were created in FM12 using themes. The solution for me was to go through the layouts with themes, change the theme then reapply the theme. It seems that there is something getting broken when opening them with 13.

            1 of 1 people found this helpful
            • 3. Re: Layout mode - FileMaker 13 not responding
              KathleenBrown

              I'm having a similar issue with a newly converted to v13 .fp7 file.

              All seems well, no consistency check errors, but after conversion we can not go into layout mode with the spinning beach ball (on a mac or spinning circle in windows).  But how does one apply/reapply classic theme if not in layout mode?

              Tried moving from v10 to v11 to v12 to v13 without any difference either.  The only other odd thing about this file, that we've lived with for years is, that when in layout mode and duplicating an object (no matter what it is) it always duplicated the item 100% on top of the original item, never offset like the behavior I've only ever seen in other files.

              Any suggestions with conversion to v13?

              • 4. Re: Layout mode - FileMaker 13 not responding
                dburnham

                I have seen this issue intermittently but I have not studied it enough to isolate when it occurs.

                 

                I sometimes find that a file goes into a non-responding mode when switching from Browse to either Find or Layout modes.

                 

                I also have seen that the keyboard shortcut for layout mode sometimes disappears altogether and I can enter layout mode by selecting it from the menu bar or the lower left section of the window.  Then, it mysteriously reappears as a working keyboard shortcut. Don't know why.

                 

                If these reported issues become the elements of a future update, I hope they will also address the behavior that began with version 12 wherein even the slightest click to select an object on a layout has a tendency to make it jump a few pixels in an unwanted direction.  The direction is not always the same, but it is always unwanted.

                 

                Regarding the location of duplicated objects it is an old rule that once you move an object after duplicating it, successive duplicates will respect the same offsets.  So if an object is landing on top of itself, try moving it somewhere before executing Duplicate again.

                • 5. Re: Layout mode - FileMaker 13 not responding
                  jormond

                  Can you go to a new layout and enter find mode?

                   

                  In the end, it may be worth a call to FMI, they may be able to help you.

                  • 6. Re: Layout mode - FileMaker 13 not responding
                    KathleenBrown

                    We can switch layouts and use the file with Find mode, manage database, seems completely fine UNTIL we try to enter Layout mode.  then it becomes unresponsive and even leaving it for 20 minutes it never responds so we force quit.  I've tried all sorts of things including creating a new layout in v10 & v11.  Used various Macs and Windows machines with various versions of FMP & FMPA and even saving the file as a clone.  Any attempts to convert any versions of these files meets with the same result. No consistency checks or Recovery report problems and so far any conversion of the variations of files has rendered it usable in Layout mode in v12 or v13.  I did call FMI but was told they have no information for me to try and there is nothing they can do. 

                     

                    Sounds like if we want to use in v12 of v13 we need to rebuild the file.

                    -k

                    • 7. Re: Layout mode - FileMaker 13 not responding
                      KathleenBrown

                      The first time duplicating any object always places it on top of itself.  Any movement of this duplication, yes, any subsequent objects are offset by that amount, it's just that the first one never is offset.  This is the only file I've ever seen this behavior in.  Thx for the reply though.

                      -k

                      • 8. Re: Layout mode - FileMaker 13 not responding
                        jormond

                        1. Go to Manage Database. And create a new table.

                        2. Go to Manage Layouts. And create a new layout based on #1.

                        3. Go to that layout and try to enter Layout mode?

                         

                        Make sure you try this also as a local, non-hosted file.

                         

                        It sounds like when FM converts the file over to 12 or 13, that the layout CSS is getting messed up.

                         

                        If that doesn't work. Create a clone of the file ( no data ) and try the same thing.

                         

                        If you can get in, then try reseting the theme on each layout.

                         

                        Edit: Make sure you do this on a COPY of the file. Not the production file itself.

                        • 9. Re: Layout mode - FileMaker 13 not responding
                          KathleenBrown

                          thanks for  the suggestion but it didn't seem to work.

                          I was excited to try something and appreciate the information!

                           

                          I was able to create a new table and the new layout was visible and seemed fine (could create and enter data in new records).  I went to Manage Layouts but clicking New here rendered FMP unresponsive as before. 

                           

                          All attempts at saving versions of this file have been on local ones and right now I have been using a clone so the conversion is faster, and yes, on a COPY for sure!

                           

                          any other ideas, I'm all ears!

                          -k

                          • 10. Re: Layout mode - FileMaker 13 not responding
                            Vyke

                            Open a copy of the original file. Remove any themes that you've applied to layouts. Convert the file to 12/13, then open the file and apply the themes to the layouts.

                            • 11. Re: Layout mode - FileMaker 13 not responding
                              KathleenBrown

                              In the original file, how do I remove themes in v11?  None were applied, but perhaps the default (of none) is causing some sort of problem during conversion.  In v12 when Layout mode goes unresponsive I can see in the formatting toolbar the Theme name of Enlightened displayed.  Perhaps this v12 default is causing a problem too.  Is there a way to set the default Theme in the newer versions v12 & v13?

                               

                              Also, in v12 / 13 I only know of setting themes in Layout mode.  Is there another way because right now, I can't get into Layout mode to work with themes.

                              -k

                              • 12. Re: Layout mode - FileMaker 13 not responding
                                Vyke

                                You can't remove a theme in <12. What you can do is create a new layout to replace the old layout and use one of the basic themes (not default). Try that and see.

                                • 13. Re: Layout mode - FileMaker 13 not responding
                                  KathleenBrown

                                  sorry if I didn't articulate my issue well enough, but I can't try this because I can't get into Layout mode at all in the converted file.  It's not just one layout that I'm having trouble with, it's ANY layout in the converted file.  And although I see that in v11 "themes" are part of the wizard process in creating a new layout, I don't see anyplace in v11 where theme info can be changed/removed.  Themes were not used in this original <12 file.

                                  -k

                                  • 14. Re: Layout mode - FileMaker 13 not responding
                                    Vyke

                                    I understand that. What I am suggesting is that you go to a copy of the original file (version fp7), recreate your layouts and apply a basic theme to them, one that is not default. Then, upgrade that file and see if that fixes it. What I believe is the issue is that, regardless of whether you select a theme in <12, theme data is applied to the file's meta info. I am thinking that, when converting, that theme meta info is either getting corrupted or is not getting converted to the new format. I think fiddling with the themes in FM11 and trying conversions on various ones might actually do something to repair or rebuild that theme data. But this is just a hunch based on the experience I have had with it so far.

                                    1 2 3 Previous Next