7 Replies Latest reply on May 6, 2014 2:30 PM by dhrowe

    How to resolve "Failed to load the widgetset" for FM Server 13

    mechai

      Hi,

       

      Anyone know how to resolve this dreaded "Failed to load the widgetset: ./VAADIN/widgetsets/com.filemaker.admin.widgetset.AdminConsoleWidgetset/com.filemaker.admin.widgetset.AdminConsoleWidgetset.nocache.js?"

       

      The "nocache.js" is the particular offending script

       

      Mavericks 10.9.2 (not server)

      Java is using version 7 update 51

       

      FileMaker version 13.0.1.224

       

      Tks for any advice

        • 1. Re: How to resolve "Failed to load the widgetset" for FM Server 13
          mikebeargie

          First thing I would do is clear the browser cache and reload.

           

          Second, make sure the referenced JS file exists:

          /Library/FileMaker Server/Admin/admin-master-tomcat/bin/admin-console/VAADIN/widgetsets/com.filemaker.admin.widgetset.AdminConsoleWidgetset/com.filemaker.admin.widgetset.AdminConsoleWidgetset.nocache.js

           

          I renamed the above file, and sure enough it broke my server console and gave me the same error dialog. Renaming it back, rebooting and clearing the cache corrected it. (Yes, I realize this was extremely dangerous but I have a test server I am specifically tearing apart in similar fashion).

           

          If the file IS missing, you can either copy it from a working server (or contact me, would be happy to send it to you), or perform a repair install that overwrites the system library folder for FM.

           

          VAADIN is the java application that the admin console is built on, however it shouldn't be an issue related to any JRE of java install itself.

          • 2. Re: How to resolve "Failed to load the widgetset" for FM Server 13
            mechai

            Hi Mike,

             

            Thanks for your suggestion. I did check the path and the nocache.js file is present and intact. I also don't think it is browser cache issue, as I download Chrome to test also. FYI, I also clear browser cache, but it just give me "Proxy Error". The key here is the Proxy Error, the nocache.js is just a side thing I guess.

             

            I would say with a reboot everything is fine, but then it returned back after the browser is sit idle there for some days. As this is our production server, it really make it unreasonable to reboot everytime we want to access Admin Console

             

            So to summarized:

             

            After a reboot it work fine, for a few hours or a few days, depending. Then the "Proxy Error" will comes in and nocache dialog message.

             

            So I think there must be somewhere wrong

            • 3. Re: How to resolve "Failed to load the widgetset" for FM Server 13
              ch0c0halic

              Can you try this? In the Terminal use the adminserver restart command.

               

              fmsadmin restart adminserver -y

               

              On FMS 13 this restarts the Admin Console app and the FMS Apache instance.

              • 4. Re: How to resolve "Failed to load the widgetset" for FM Server 13
                mechai

                Oh I have CWP XML where outside world is viewing through a web application (Ruby) and also in the office we have many people connected to the database through FM client, will this affect them? Or it only really affect the Admin console and the VAADIN thing.

                 

                Tks for help

                • 5. Re: How to resolve "Failed to load the widgetset" for FM Server 13
                  mechai

                  WOW.. tks ch0c0halic, you have solved my issue. The answer simply lies in restarting the admin-console using the command you suggested. It will just restart the console and not the database server, so safe to perform. Tks a million

                   

                  fmsadmin restart adminserver -y

                  • 7. Re: How to resolve "Failed to load the widgetset" for FM Server 13
                    dhrowe

                    OBTW - I got this error on W2008 updating my dev server from 13.0.1 -> 13.0.2 today.

                     

                    The files are in a different place on the FMS in windows ( and maybe on 13.0.2 mac too ).

                     

                    did not solve problem but can work around problem with:

                     

                    Clear cache,

                    Reboot server ( all not just the console )

                    -- when you want to pull up the console.

                    Start up localhost:16001 to view the start page and click open console from that.