6 Replies Latest reply on Apr 8, 2014 4:09 PM by PeterGort

    Weird auto-opening behaviour

    PeterGort

      Hi All,

       

      I’ve come across a weird behaviour and thought I’d ask if anybody has any wisdom on the matter.

       

      I’m attempting to build a “Roll Call” dedicated file to be run on iOS devices. I set the file to open automatically with the guest account. Then I embedded it in a container field in the hosted school admin system. The client opens up the hosted system using an iPad, taps on “Roll Call”, and the file stored in the container field is then downloaded to temporary items location on the iPad, with the “open file” checkbox checked in the “Export field contents” dialog.

       

      When I tested it on a desktop computer, worked perfectly.

       

      When I tested it on iPad, I found that it ignores the “open automatically” file option and presents a username and password dialog. Hitting “guest” works and the routines work fine from then on.

       

      So I thought I would generate a sample file to send to our FileMaker Systems Engineer, illustrating the problem. But the sample file I created, using a simple database file with no content to speak of, worked perfectly on iPad. So something I have added to my Roll Call file is causing it to put up the user authentication dialog when opening (only in FM Go), even though it is set to use [guest]. At this point I’m going to have to start adding things into the testfile that works until it breaks, and this will probably take a considerable time, so I thought I’d ask if anybody has any knowledge about this behaviour, or seen it before?

       

      This is in v13 btw.


      Peter Gort