JohnValeanBaily

Communication Breakdown

Discussion created by JohnValeanBaily on Apr 21, 2014
Latest reply on Apr 22, 2014 by DavidZakary

I recently had need to work with Document Management and the external container processes using Mavericks and FMS 13. I’m using a MacMini running Mavericks as a server (8gig RAM).

 

The one file is 16.3 gig, which I uploaded to the server using FMPA13’s upload process. Once on the server, I ran the external container enabling processes, reducing the file from 16 GiG to 60 Mb. No reported errors.

 

Tested the file from a client using FMPA 13. It works fine.

 

As a last test, I then tried to use the Admin Server capability to download the (closed) file to my client desktop using the Download Database command.

 

After five minutes I got a Communication problem, error 404.

Tried again same thing.

Tried another file (163 gig) on another server, same processes, same error.

Ran the Recover on the file locally, no reported errors.

Duplicated the upload/container processes, same error.

 

Contacted FMI Tech Support. Paid my money, they started delving.

They used my original file (sans pictures) of about 60 Mbytes.

 

They could not reproduce the problem until they ballooned the file up to 16 Gig, at which size the error worked flawlessly !

 

Here’s the response from the excellent techie, Matthew, verbatim:

 

“I have tested downloading both mine and your file. I have also both tested with having the data transferred externally and only being stored internally. In all cases, when the file is ballooned to 16GB, the 404 error you mentioned does occur. This is likely a limitation of the server software itself. If an immediate workaround is required, I recommend either performing regular backups which compress the file and external contents or copying the file and data itself directly to a backup drive.”

 

(my emphasis)

 

I suspect a fix is in the works...

 

HTH

Outcomes