4 Replies Latest reply on Apr 26, 2014 6:26 PM by bigtom

    Insert From Device error

    bigtom

      I am getting an error when trying to insert an image from device script step. The script specifies a container field that is set to image data type and is an embedded container. The script specifies the camera to insert the image.

       

      I get an error that the destination field is not the correct field type and the script will not save. Maybe there is something I am missing, but it all looks right.

        • 1. Re: Insert From Device error
          taylorsharpe

          What version of FM Go?  And what version of iOS?  Would you mind sharing your script here so we can look more closely at it?  Have you verified there is not a permissions issue?  Is the "Specify target field" checked and is it a container field?  Have you tried it on multiple iOS devices and get the same failure?

          • 2. Re: Insert From Device error
            jbante

            I recently ran into a similar issue. I ran into it when inserting a barcode scanned via the on-device camera. Specifically, but button triggering it was called from a portal row. When the target field was a global field outside the portal, FileMaker gave me the same error it gave you, that the target field is not the correct type. When I used a different target field within the portal row, it worked fine. I tried fields both outside and inside the portal, and it didn't matter whether the target field was a text field or a container field (both of which are supported as the target of the Insert From Device script step for scanning barcodes). I haven't isolated exactly what the problem was because I did get something working and I had to move on. I'm eager to hear if anyone knows exactly what the issue is.

            • 3. Re: Insert From Device error
              bigtom

              Taylor,

              Seems to be working on a different device. FMGo 13. Both on the most current iOS. Logged in as the same user on both. I added the option to run with full permision. Will check on the original device and see whats up.

               

              Jeremy,

              Thanks for the insight I will let you know if I figure it out.

              • 4. Re: Insert From Device error
                bigtom

                Works now. Tried with the full access on and off and it works the same. Weird as I spent some time working on this and realy did not change anything essentially. This kind of behavior scares me.