AnsweredAssumed Answered

How to prevent Leading underscore in Fieldname when importing cells with leading zeros from Excel

Question asked by user22423 on May 2, 2014
Latest reply on May 2, 2014 by Malcolm

I have a problem with importing a spreadsheet from Excel into FMP. Only fields with leading zeros get an underscore into FMP. How do I get rid of them?

 

Context:

Preparing table in FMP to fill with data from the solution to finally deliver a prepared exportfile to Excel again. The tables are very big (lot of fields and record) and I prepare those in Excel.

 

Problem:

I can open the files in FMP and I'm asked to put the first row into fieldnames of the record. That's very nice. I do so. Then FMP makes a new database from the table. When I go to the database design I see that All fields which are interpreted with numbers have a leading underscore. See table below what I mean.

 

 

Source in ExcelFieldname after import in Filemaker ProResult
MM_IDMM_IDFine
K_TP_NAMEK_TP_NAMEFine
001_MSASSS_001_MSASSSBad



 

This screenshot is from Excel. The first row from this sheet is imported to fieldnames in one table in FMP. All cells have a text format but are interprete differently in FMP in the import process.

 

Screen Shot 2014-05-02 at 11.57.13.jpg

This is of course the reason ... It is possible to change the fieldname afterwards but FMP doesn't like it.

 

Screen Shot 2014-05-02 at 12.34.26.png

 

 

Questions:

 

As said, the tables are very big to manually change the filednames. Is there a posibility to ommit the preceeding underscores when importing from Excel? And as you see, this only happens when FMP interpretes the first digits as a number. And of course, is it wise to work with leading zeros in filenames? I choose for this option because I want to export from the solution as is imported from Excel and I want to prevent extra sort procedures.

 

 

Thanks in advance,

Harold

Outcomes