12 Replies Latest reply on Aug 16, 2017 3:20 AM by wimdecorte

    FMS13 does not start

    jorber

      Installed FMS13 succesfully on a Mac OS X 10.9.2 computer. After restart of the computer the server did not start. There is no web-servise and I can't use the adminconsole on port 16001. How to restart the FMS and webservice?

        • 1. Re: FMS13 does not start
          mikebeargie

          Have you tried using command line through the terminal to start it?

           

          Here's a good introduction to using the command line if you never have before:

          http://www.rcconsulting.com/Downloads/FMS12_Processes.pdf

          • 2. Re: FMS13 does not start
            jorber

            Thank you for the suggestion. Since I not very familiar with the comand line I do not now if I do it the right way. When typing sudo apachectl start com.filemaker.fms I just get instructions of Usage: and Options: but the server does not seems to start according to Activity monitor or browser tests.

            • 3. Re: FMS13 does not start
              mikebeargie

              Read the full paper please, you just read down to the first command which was for the helper and not the server itself.

               

              The commands you need are:

               

              fmsadmin start server (or restart server) - for the filemaker server

              fmsadmin start adminserver (or restart adminserver) - for the admin console

               

              for both commands you should be prompted for your admin console username and password in the command line.

              • 4. Re: FMS13 does not start
                jorber

                My apologies for my ignorance in this subject but using those comands just gives: Error: 10007 (Requested object does not exist)

                Should I be in a specific directory executing the commands?

                • 5. Re: FMS13 does not start
                  mikebeargie

                  fmsadmin is a process so it's not directory specific. I normally see error 10007 with "out of memory" situations, I normally restart the script server to solve those:

                   

                  fmsadmin restart fmse

                   

                  But I doubt this would be an issue on a new install.

                   

                  What are the processor/ram specs on your server?

                   

                  Are you seeing any fm___ processes running in the Mac OSX activity monitor (see screenshot in page 2 in above document)?

                  • 6. Re: FMS13 does not start
                    jorber

                    fmsadmin restart fmse also gives 10007. Processor:  2,8 GHz Intel Core i7 Memory: 8 GB 1067 MHz DDR3. No fm* processes running according to Activity monitor.

                    • 7. Re: FMS13 does not start
                      sibrcode

                      I've had some situtations where launchd (an OS component that is responsible for launching FMS) gets confused, and needs the FMS plist to be reloaded. This is fixed the issue for me:

                       

                      sudo launchctl unload /Library/LaunchDaemons/com.filemaker.fms.plist

                      sudo launchctl load /Library/LaunchDaemons/com.filemaker.fms.plist

                       

                      If it still doesn't launch after you might want to check the logs at /var/log/system.log and /Library/FileMaker Server/Logs/Event.log for any relevant issues.

                       

                      Simon.

                      1 of 1 people found this helpful
                      • 8. Re: FMS13 does not start
                        jorber

                        Thank you!

                        This solved it all.

                         

                        • 9. Re: FMS13 does not start
                          dburnham

                          Mike,  maybe you have the answer to this.  I was seeing error 10007 this morning on my FMS-12 (Mac) server.  Hard to tell whether memory is the issue because the new "memory pressure" thing appears to consume all the hard wired RAM.  It's *GB machine running nothing but FMS and the list of running items adds up to 3.4GB.

                           

                          Several restarts eventually got the fmserver process running again.   What I did just prior to accidental success when no fm processes at all were running was delete the Java "temporary files."  That, followed by a restart, got the database server running again but I can't get the admin server to launch.  Can't start it with the HTML page that would normally fire it up, but Terminal reports that fmased is running.   When I execute the command  sudo fmsadmin restart adminserver, it queries me with the "Really? question and when I answer Y, the admin server goes into Non Responding status in the Activity Monitor.

                           

                          Suggestion?

                          • 10. Re: FMS13 does not start
                            wimdecorte

                            You can also try to restart just the FMS script engine from the command line and see if that reclaims any memory:

                             

                            fmsadmin restart fmse

                            • 11. Re: FMS13 does not start
                              eworbit

                              In the past couple weeks my FMS16.0.2 has crashed on a database and the entire fmserver won't start back up!  Normally, after OSX Sierra reboots, the file is verified and comes up fairly quickly.  But twice now it's been bad.

                               

                              (By the way, I think I've determined the crashes are due to Actual Technologies' ODBC driver).  Anyway, normally things just come back up.

                               

                              But since FMS16, the server gives me "Error: 10007 (Requested object does not exist)" when trying $ fmsadmin start server.

                               

                              I've tried the launchctl unload/load solution noted above and rebooted but no luck.  Still the 10007 error.

                               

                              $ sudo launchctl list |grep filemaker

                              and

                              $ ps -ef

                              indeed show fms not running.

                               

                              So, I'm forced to completely reinstall FMS16 and within an hour I'm back up and running normally.   Somehow OSX is crippling (dare I say "PUNISHING"?) filemaker and I don't know how to inspect all the OSX level settings to narrow down what breaks.

                               

                              Very frustrating.

                               

                              -Eric Wood

                              • 12. Re: FMS13 does not start
                                wimdecorte

                                how do you do the load/unload?

                                 

                                sudo launchctl stop com.filemaker.fms ?

                                 

                                This:

                                eworbit wrote:

                                ...after OSX Sierra reboots, the file is verified and comes up fairly quickly...

                                 

                                Is not good practice and may contribute to and make the problem progressively worse.  Restore from a backup when this happens so that you can be sure that there is no new damage to the file.  Until this is resolved, go with an aggressive backup strategy.