7 Replies Latest reply on Oct 3, 2014 6:43 PM by ch0c0halic

    Save as PDF differs in 13 from 12

    jrenfrew

      I have a FMP 12 file hosted in my office for quotes witha script to create a PDF of the current record to the documents folder and automatically open it

       

      Ona variety of Macs from 10.8.5 ot 10.8.9...

      WIth FMP12 the script works fine, run it again it works fine, run it aain it works fine... change somethign run it agian it works fine.... you get the idea

       

       

      FMP13 (13.0.2) run it, it works.... run it again NO WORKIO. tells me the disk is full or locked (see attached) Wierd thign if I change the path to include Get ( tempdir) rather then Get (docsdir) it works, and it works on paths above the Users folder level.

       

      this is on all the Macs

      and the only way to fix it is to reboot. What! just like owning a PC from 15 years ago.

       

      run the script, it works, then again and it doesnt

       

       

      This SEEMS like a pretty huge issue to me... anyone else seeing this behaviour?

       

       

       

      john

       

      Screen Shot 2014-05-29 at 18.29.29.png

        • 1. Re: Save as PDF differs in 13 from 12
          deninger

          First guess:

           

          Could it be that the first time you run it and the PDF opens automatically you forgot to CLOSE the file? If the file is open, it is locked by the OS and FM 13 appears to object to overwriting it (a good thing).

           

          Try closing the document first and they re-running the script.

           

          The Get (TemporaryPath) avoids this problem as the path actually changes and the file does not try to "stomp" on the previous file.

           

          I tried reproducing this myself on 10.9.x but it asks me if I want to replace the file. It is possible that 10.8.x behaves differently with respect to locking the file).

           

          Message was edited by: deninger

          • 2. Re: Save as PDF differs in 13 from 12
            jrenfrew

            Hmmm, thanks but no not that naive....

             

            Ane the temp path only changes between sessions, not during...

             

            john

            • 3. Re: Save as PDF differs in 13 from 12
              keywords

              Can you post the script—or at least the relevant steps?

              • 4. Re: Save as PDF differs in 13 from 12
                fabianf

                Same problem here. We are on OS X 10.8-10.9 and save on an OS X server. Everything worked fine in FM12, but in FM13 it is exactly as you write, that it works a couple of times and then no longer. I have been checking permissions on the file server, thinking like deninger here that it happened only when someone tried to overwrite an old document with the same name, but that is not the case. Originally I thought that the users had forgotten to log on to the file server... but that is not the case.

                 

                One weird thing is that it happens to all users except me. The differences I can see is that 1) I log into the file server with full permissions, 2) I have full permissions in Filemaker and 3) I run Filemaker Advanced.

                 

                I tried to reproduce the error on my machine by using another Filemaker account with the same permissions as the others, as well as another log in to the file server with the same permissions, but I couldn't make it happen. I didn't think about Filemaker Advanced at this point.

                 

                We are getting quite desparate about this now, as it means all users need to restart a couple of times a day, which off course means they want to switch back to FM12.

                 

                jrenfrew, have you found a solution?

                • 5. Re: Save as PDF differs in 13 from 12
                  jrenfrew

                  unfortunately not

                  • 6. Re: Save as PDF differs in 13 from 12
                    fabianf

                    There is another known bug for which there is a solution. I believe most people here already did this, which is why they fail to get this save-as-pdf-bug, but that's my theory.

                     

                    Anyway, after deleting the Adobe PDF plug-ins under Library -> Internet support, this bug DISAPPEARS for all my team members.

                     

                    See also http://forums.filemaker.com/posts/43931f62da?commentId=306805#306805

                    • 7. Re: Save as PDF differs in 13 from 12
                      ch0c0halic

                      There is a 'known incompatibility' between some versions of the Adobe PDF plugin and FMP. This has been brought up before.

                       

                      You should be able to update the PDF plugin to the latest version, I think its 11, and FMP should still work.

                       

                      YMMV

                       

                       

                      A 'known incompatibility' means someone said it and someone else corroborated it.