5 Replies Latest reply on Jun 4, 2014 5:08 PM by keywords

    How do I prevent truncating on  large fields on a report?

    jthomas

      I have a survey application that I have developed for the risk management department. The surveys are performed on iPads us ipad Go version 13.4. The user goes through a list of criteria on the iPad and checks off anysafety that are not up to standards.

      At the end of the survey a report is printed listing all the checked criteria. The problem I having is that when there is a large quesstion the end of the question is truncated. If I increase the size of the field the first page is blank except for the header. The survey used to be on MS access and any large field would just continueon the next page. How do I do this in Filemaker?

        • 1. Re: How do I prevent truncating on  large fields on a report?
          ryantittle

          On the Position tab of the Inspector in Layout Mode, there is a Sliding and Visiblity section. Try adding the "slide object up based on all objects above" and  "also resize enclosing part" options. You will need to select this for the field in question as well as anything below it. This way the field will only be larger when you need it to be. Page break options for the Parts of your layout may come into play as well.

          • 2. Re: How do I prevent truncating on  large fields on a report?
            beverly

            Except this is on iPad and therefore only browse mode (not preview mode). What sliding is supposed to happen on iPad (FMGo)?

             

            Beverly

            • 3. Re: How do I prevent truncating on  large fields on a report?
              jlamprecht

              I believe the sliding will still occur during printing. This could fix the issue for the printed out form.

               

              Fixing it in Browse mode is a different situation. As Beverly says, iPad will be in Browse mode. Preview mode is not supported.

               

              My suggestion is make the text field scrollable and let the users scroll down criteria that are large.

               

              I hope this helps.

               

              Edit: Apologies. My eyes are bad today I guess

              • 4. Re: How do I prevent truncating on  large fields on a report?
                Stephen Huston

                In addition to the Sliding and shrinking enclosing parts, on your reporting layout, use merged text with your fields inserted, and they will wrap until you reach the actual max-setting for your layout object or part. Make your layout parts large on the report layout so the content will fit, but set to slide and shrink for the output.

                 

                If your questions are in separate records you can effectively place each question/answer block of merged text into its own overly-large part set to slide and shrink, getting a consistent spacing between items in the actual output.

                • 5. Re: How do I prevent truncating on  large fields on a report?
                  keywords

                  From you description of the issue, and taking into account the comments already offered, I would just add that this sounds like you need two layouts, one designed as an iPad UI and another designed for a report, whether printed or electronic—either viewing on the device or saving as a pdf, say. The report layout could the use a series of fields, a single concatenated field, or text object(s) with merge data and utilise the sliding options as needed, while the UI layout need not be compromised by any of these considerations.