4 Replies Latest reply on Jun 6, 2014 7:38 AM by SteveMartino

    New Record problem

    SteveMartino

      Hello Forum. I seem to have a problem, hopefully easy, on a very simple database I made to index some training videos. It consists of 2 tables, Topic & Sub-Topic. Sub topic is a portal in Topic. When I try to create a new record, either by a scripted button, or by a menu choice, the area for Topic goes blank (as expected) but the records in the portal stay there--basically changing the record. I tried running recovery, which showed everything was ok. Here's the file. Simply click any field in the opening layout to GTRR, then try clicking the new record button, or new record thru the toolbar/menu.

      Any thoughts would be greatly appreciated.

      Thanks

      Steve

      FM Pro 12 adv, Windows 7

        • 1. Re: New Record problem
          erolst

          There is/was a number of sub-topic records with currently non-existing FKs, which were then “grabbed“ by any newly created topic with a matching PK.

           

          Past Topic PK 41 this “phenomenon” will disappear.

          • 2. Re: New Record problem
            SteveMartino

            Thanks for your quick reply.  Now to reply to your answer..............huh?...lol.  I'm sorry for my newbie-ness, but I don't know what you mean, what I did wrong, and how to fix it.  If you could point me in the right direction I would greately appreciate it.

            Steve

             

            Nevermind...you pointed me in the right direction and I got it fixed.  Now a better question, how did you figure it out....that's the genius

            Thanks

            Steve

            • 3. Re: New Record problem
              coherentkris

              Seems to me that the auto increment setting for the Topic table primary key is out of sync with actual conditions. The topic table has 36 records, the max value in the primary key field field is 41, and the auto increment next value is set to 36. The primary key should be unique AND always have next increment value set to 1 greater than the max.

              1 of 1 people found this helpful
              • 4. Re: New Record problem
                SteveMartino

                I just noticed that...cant figure out how that happened, maybe when I imported the records from iPad back to desktop.  I also have duplicates.

                Edit:  It was an Import issue...duplicating records.  All better now..(i think)

                Thanks for taking the time to respond.

                Steve