5 Replies Latest reply on Dec 8, 2014 3:28 AM by disabled_xaviervb

    Cannot play mp3 files via webdirect

    GAmstutz

      I've setup container fields in which I'm storing MP3 files.

       

      When I open the layoug showing these container fields in FileMaker, I get a media player that allows the user to play the mp3 file and listen to it:

       

      Screen Shot 2014-06-21 at 3.01.35 AM.png

       

      However, when I open the same layout in FM WebDirect, I get the following

       

      Screen Shot 2014-06-21 at 3.01.10 AM.png

       

      And the user can't play the MP3 files from the web browser.

       

      Is there a solution to this (some setting I'm missing int he container field)? Is the only solution to make buttons for each container field with scripts to export the MP3 files when the user is using a web browser?

       

      Is there a way to play an mp3 file directly within the web browser using WebDirect?

        • 1. Re: Cannot play mp3 files via webdirect
          mikebeargie

          Works for me, I am using chrome, something must be up with your settings.

           

          Have you tried an alternate browser, and have you made sure you have the quicktime plugin installed and approved to work on your WD page?

          • 2. Re: Cannot play mp3 files via webdirect
            GAmstutz

            It's not just me, it's all my clients using my FM solution via WebDirect.  None of them can play the MP3 files through web browsers.  We've tried Safari, Chrome, Firefox...all fail.

             

            Most of the clients are using Macs, and it fails for them, too (a special QT plugin shouldn't be needed on Macs, right?)

             

            No, it seems to me it's a problem with my FM settings since it happes to everyone via WebDirect.

             

            Works fine in FileMaker Pro and FileMaker Go. 

             

            I've tried turning on and off the container's field's interactive settings, but it doesn't help.

             

            Any other suggestions for setting changes?

             

            Guess I'm going to have to write a download and play script for each file for Web Direct users? (anyone know why this doesn't work the same in Web Direct as it does in FMP and FMG?)

            • 3. Re: Cannot play mp3 files via webdirect
              mikebeargie

              How are your containers stored?

               

              If it's all of your users, then you've most likely set up your storage in a way that does not allow web users to access and stream the file.

               

              quicktime is required (as far as I can tell), but you should get a status bar message asking for either permission to install or permission to use the quicktime plugin when you press play in a field.

               

              As noted by my test, it can work just fine. Something is just set up wrong in your file. If you want to give up troubleshooting though and create a download script for your webdirect users, that certainly is a possibility.

               

              Try making a sample file. Just create a new file, single table, single layout, single container field, single record, insert an mp3 file. Use all of the filemaker default settings. Host it and access it from webdirect. Does it work?

              • 4. Re: Cannot play mp3 files via webdirect
                gladams

                Did you manage to resolve this issue? I'm having the same problem. mp3 files work fine in FileMaker, but do not work in WebDirect on my 2 windows machines or Mac laptop. You just see the icon. I'm using a hosting company FMPHost and wondering if the problem lies with them, since they seem to work for Mike.

                • 5. Re: Cannot play mp3 files via webdirect

                  I read somewhere you should check if the filemaker server ports are correctly open. Hope this helps.